Why did Postman erase all my collections?

Describe the bug
That’s rather a rant about app misbehaviour than a bug !
I was using Postman without signing-in because, you know I’m not fond of signing-in everywhere.
It has been quite a long time since I didn’t open the app, so I was not aware of the latest changes.

Anyways, I had some requests stored in local collections. I’m using it to test some services I happen to work with.

Today, I needed to test one of those services, so I opened Postman. At the first screen I was ~prompted~ forced to log in. I found no way to avoid it so I thought “what the hell, let’s login”.

The second after being logged in, I noticed that the collections I had disappeared.
First I thought that there were on an other account (pro vs personal gMail) so I proceeded to login to the other account.
And then again, no collections. All have disappeared !!

Expected behavior
Seriously, why not keep collections stored after logging-out ? It’s not like they weigh GBs !
And why erasing collections that were originally not linked to any account

App information (please complete the following information):

  • Postman for Linux Native App
  • Postman Version 6.7.1
  • OS: Ubuntu 18.04 LTS linux 4.15.0-62-generic / x64

Additional context
Please tell me my local collection are only hidden somewhere

Hi @bwhisp

Welcome to community :wave:
I understand how frustrating it is to lose your collection, this isn’t the kind of experience we want our users to have.

Once you login to the application, all of your collections are synced to your account. You can check the same by navigating to the links here:

If the collections are synced, please try to re-login to your application which should populate all of the collections back. Else, let’s share them back to the respective workspace.

The problem is I never logged in before, so the collections that I stored were locally stored.
And… now they’re lost, at least according to what I can see.
Out of doubt I tried to login with 2 different accounts that I might have used at a moment but I found nothing.

If you have never signed in earlier and then you were forced to sign in, then it probably looks like a bug. May I know if you received the same modal to sign in?

To check this from our end, can you please provide your email accounts associated with Postman?

@bwhisp Also, can you please try to recover the data, if available locally? Below document should guide you on the same.

I used 2 accounts but I really don’t think they are related to that:

1 Like

I found 2 files that could correspond to those cited in the tutorial.
I’ll try them on this evening :

But I think those files are associated, each with one of the account I logged in Postman

Well I just tested the method you suggested and it looks like the 2 files I mentioned having found are corresponding to my 2 accounts.
So, I lost the data I have stored locally :frowning:


I believe you have tried copying data within the file: /snap/postman/80/.config/Postman/IndexedDB/file__0.indexeddb.leveldb/ to Canary location ~/.config/PostmanCanary/IndexedDB/. If not yet, please try the same and check if any data locally stored can be recovered.

Apologies for the inconvenience caused. We are tracking these workflows and working towards fixing them at the earliest.

Please feel free to write to us at help@getpostman.com for further assistance.

I’ve tried with both :

without success :frowning_face: