Lost All Collections When I Created An Account

I have been using Postman for a while now and had created many (over 100?) requests in several collections. I decided today that I would hate to lose these, and saw that one of the benefits of creating an account was “Backup your data to the Postman cloud”. So I created an account & signed in… and I now have an empty workspace. All of my collections and requests are gone. I signed out, and still gone.
Ironic, huh?
How do I restore them?

1 Like

If you login to https://web.postman.co do you see any of your data?

Also curious, were you using the Free tier and the upgraded to Pro? Or were you just not logged into the app and then decided to sign up for the Free tier?

Thanks for replying.
When I log in, it’s empty.
I was just not logged into the app and then decided to sign up for the Free tier.

That is really odd because I just tried this locally and was not able to replicate the issue.

Can you tell us what OS and Version of the app you are running?

@crutchMan FYI the exact same thing happened to me last week! I had hundreds of api endpoints and a dozen environments setup locally only. Then I decided that I should try to create an online account, but I didn’t immediately sync anything, just signed up with intention to hit that sync button “soon”… then a few days later (5 days ago) I was happily using Postman and then the Postman app flashed/blinked/wigged out for a moment and BAAAAM, all of my endpoints and environments were wiped out. Not workspaces, collections, nada. They were not synced to the cloud and I couldn’t get them to show locally. Tried reinstalling. Tried upgrading the the most recent version (was one version behind). Nothing worked.

I gave up trying, after I found some article that said it might be some database corruption, and asked for a co-worker to provide me with their setup (which I had exported for him a few months back). Still missing a lot, but I’m thankful I have something.

@tmccann my OS is Windows 10 Enterprise Version 1803 build 17134.590. I now have Postman v7.0.9, but like I said the problem occurred just before I upgraded, not sure which version that was.

1 Like

One more note, none of my coworkers had the same problem. I was the only one with data loss. We are on the same OS, but not sure about the exact version of postman. But I was the only one stupid enough to not have a backup of some type.

FYI, here’s the response I got from support:

Would like to inform you that we have fixed this in our 7.0.9 version but the solution won’t apply here since you are on 7.0.7, the backup will not be there.

Looks like I am out of luck.

This seems like a specific scenario. I looked at the list of big fixes and didn’t see one that specifically met this criteria, however I didn’t read the specifics on every bug fix though.

@Chris Do you know anything more about this?