Postman not starting up - stuck in preparing workspace

Win 10 box, when i try to start up postman, its just stuck.

I have un-installed, deleted both directories (appdata) and re-installed.
I have also tried to start it up from command line and its the same issue.
Also, i didnt have NODE_OPTIONS in my env variable.

Anything else that i could try?

Hi @RichardBarrett

Can you try the steps mentioned in this below thread once again and let us know if that helps?

If the issue persists, would you install our Canary build to see if it opens as expected?

The canary build will be installed an entirely separate app/directory – if it works as expected, feel free to continue using it or to uninstall it entirely.

I tried the Canary build and i got the exact same behavior (where i am stuck loading):
Preparing your workspaces…

I have also tried un-installing and deleting the two postman folders, same issue.

@RichardBarrett It looks like you are running into a known issue which is currently being tracked on GitHub tracker and below is the link for the same:

Can you try installing the previous version of the application v6, that appears to be working in this case for other users who have reported the same? Hope this helps!

Link to download v6: https://learning.getpostman.com/docs/postman-pro/managing-pro/migrating-to-v7/#download-latest-postman-v6-app

that worked, thanks for your help (note, assuming that there is some auto update as i have not updated things in a few months, for this to occur).

1 Like

I have the same problem on Win 10. Uninstalled Postman and installed an old version - now everything runs again. Colleagues can run latest version on the same setup. Looks strange to me?

1 Like

Hi @markus.wolf :slight_smile:

Yes and that isn’t the expected way out. We are aware of this issue and are currently tracking this on below GitHub link as mentioned in my earlier response:

Do subscribe to the thread to receive latest notifications on this issue.

Hi,
My postman stuck on Mac with the same messege.
Any idea?
Thanks, Adi

Hi @Adishab - could you follow the steps mentioned in the article below and see if that helps?

Hi,
Thanks for the fast feedback.
The issue fixed by itself in the day after… strange.
Thanks anyway,
Adi

1 Like