Postman desktop failed while postman web succeeded

hi guys,

I’m trying to make a program to retrieve sales from my marketplace.
so it seems I have to learn my way through postman.

I’m still just trying to get a token from authorization.
I succeeded doing this with postman web, but always failed with postman desktop.
it always got error “callback timed out” after about 1 minute, while on postman web, it succeeded getting the token in about 1-2 secs only.

what should I do ?

I’ve already tried :

  • disable my windows firewall.
  • I didnt disable my antivirus, but I only used defender and I dont think defender ever block any of my programs.
  • I have tried to disable the firewall on my router too.

but it’s still the same.
why the postman desktop couldnt get the token ?
I still dont know how to convert this later to my program, but I think it’s crucial that the postman desktop to get the token because if it’s not, then my program wouldnt be able to get the token too later since it would run on my computer ?

thx for all the answers

That error usually means that the server is responding but the server is too slow sending back part of the response.

Have a look if you have timeout settings applied.

Settings > General > Request timeout

But its been a minute. And like I said, if I tried from postman web, it only needs 1-2 secs to respond.
So it shouldnt be too long that it would be different more than a minute ?

It was just something to try. Did you try increasing the timeout (or was it set to zero which is no timeout)?

I can’t think why it would run slower from the desktop app.

As the site is using HTTPS, I would also potentially disable the SSL checks as a test to see if that makes any difference.

u mean the “request timeout in ms” ?
it was 0.
and from the remark, it said “To never time out, set to 0”.
so it was set to never time out, but it timed out nevertheless

how to disable ssl ?

It’s under the settings on the request.

it was disabled by default as well

any other idea ?

I have even tried to install the postman desktop on my laptop and bring it to another house (means another internet provider, router, etc as well)
and basically the same.
postman desktop callback timed out, as postman web worked in 1-2 secs

I just tried it on my dedicated web server, that should have almost all port open And it still the same.
I started to think the problem is the postman desktop itself, or at least the default setting of the postman desktop

I’m not sure what else to try. I have the desktop on a couple of machines including work ones which are locked down tight, and I don’t generally have issues connecting to API’s, internal or external, HTTPS or otherwise.

What do you have under the proxy settings? Anything in there that might be getting in the way?

all unchecked
except “use system proxy”

so I tried unchecked it, and try again…
still the same
this is so weird. I couldnt even begin to learn how to use oauth 2.0 and has only messed with postman desktop settings these few days =="