Connect ETIMEDOUT from (latest) Postman App / Browser version succesfull

My question:
When I try to send a request to the Jira Cloud API I have different results comparing the Postman Desktop App (Running latest version on Windows 10) vs. running from in Google Chrome.

How I found the problem:
From the Desktop App I get a “Could not send request” error (Error: Request Timed out).
Console specifies just the Error: connect ETIMEDOUT

When I log on to, use the same Workspace and the same request my response is succesfull and swift.

I’ve already tried:
I already searched the internet and tried the option of launching Postman with the Proxy variables cleared.
I also tried to replicate my browser Proxy settings in the Desktop App to no avail.

Any thoughts on how to tackle this?
I may have to provide the answer to our IT department as they have no experience with Postman at all.

Details (like screenshots):
Console results from Browser:

Results from Desktop App:

Postman version:

Hope anyone can help me get this sorted.