Postman online and desktop app : Oauth 2.0 authorization


I have been using Postman for some time now to access an API. I mainly use Postman online and I have a problem with the authorization to access the API.

Previously it worked from the “Authorization” tab (OAuth 2.0), I got the token and then I could do whatever I wanted. I haven’t changed anything on my side, but now the authorization doesn’t work anymore (Error: Request timed out). So I guess there has been a change on the Postman side ? Or broswer parameters ?

On the other hand, if I use the desktop app installed directly on the PC, it works with the same connection settings, I get the token. I tried with another browser for Postman online and I have the same problem (authorization and token retrieval impossible with Postman online but ok with the installed software).

Does anyone know where the problem might be coming from?

Thank you in advance for your help !

The desktop runs the requests locally from your network, where the web client runs the requests from the Postman Cloud. (Aka the Internet)

If the requests are timing out from the web client, then its probably a connectivity issue to your authorisation server.

Has there been any changes to the firewall or network configuration to prevent access to the authorisation server from the Internet.

Thank you for your response and clarification. I have not made any changes to my firewall or network configuration.

So it could be changes made on the API provider’s side to block access?

Potentially, if they have added whitelisting or similar.

I guess a conversation with the supplier is your next step.

Okay, thank you for your responses. I will check with them.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.