My Postman desktop agent does not open

HI everyone,

My desktop agent does not open at all. I press the icon it does no action. I am using it on Windows. And Postman web app does not show desktop agent as active saying download desktop agent. I do not how to fix it. Can anyone help?

Hey @jmammadli :wave:

Welcome to the Postman community :postman:

Do any of these help solve the issues you’re facing?

The desktop agent doesn’t open like the app would, it’s a agent that runs in the background but is visable on the task/menu bar.

HI Danny. Desktop agent is not available It suddenly stopped and has not worked since. What can I do about it?

“If the Desktop Agent reads any error, select Check for updates > open the Desktop agent and refresh the web page.” Where can I check for updates? cannot find that button anywhere

Are you able to share screenshots of what you’re doing / what you can see?

It makes it easier when you’re describing something that you can see on the UI. :pray:t2:

I have a similar issue. I believe the problem is with v11 upgrade. I updated my packages using winget and Postman is now at v11.0.0. It first opened with a screen telling me my (free) team is restricted to v10. Upon restarting my device, it looks like the package has disappeared. I can’t uninstall or reinstall it.


Hey @ahmedsabriz :wave:

Welcome to the Postman Community! :postman:

This is not the same problem, the winget package was updated to a non active version.

The screen that opens, has a Download v10 button on it and you can use this to download the V10 version. Close the instance with this displayed message you’re seeing and then open up the newly downloaded version.

Alternatively, it can be downloaded from here:


Thanks Danny. Now that I read it again, I realise it’s a different issue I just confused the symptoms. It was just strange that after closing the instance I could not open again and Windows told me the shortcut dies not exist like the app erased itself.

Anyway, sorry for hijacking this. I fixed it with winget install Postman.Postman --version 10.24.16 --force

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.