Day 27 Challenge: 404

I’m working on Day 27 of the 30 day challenge. Every time I try to post a new user, I’m getting a 404 Status. Is the server down? Is something else wrong?

To confirm, I’ve been using this YAML file to import “The Good Bank APIs”: vulnerable-apis/openAPISpecBank.yaml at main · kmmanoj96/vulnerable-apis · GitHub

I also have the collection and the API in my “The Good Bank APIs”. Not sure what else to do here.

Hey @altimetry-cosmolog18

This URL seems to be working fine for me:

I kept the full URL in view and not in a variable for visibility.

I did see that your request is working as it’s returning an error about the format of you request body.

If you fix that and create a new user, you should be able to continue with the taks for that Day.

Hey @danny-dainton , thanks for the reply. Unfortunately, I’m still getting a 404 on my end.

I even took out the variable and used the full URL, and it’s still not working as expected. Any other ideas on what I might be doing wrong?

I’m also getting a 404 when I just try pinging the server. Is there additional set up that I forgot to do somewhere?

Here’s what I get from running the curl command:

Mac:~ anne.juan$ curl --location '' \
> --header 'Accept: application/json'
404 Not Found

I don’t know what’s happening for you here - It’s returning a 200 code for me. :thinking:

This is the basic cURL command i’m using:

curl '' -H 'Accept: application/json'

What do the full request details look like in the Postman Console? Anything out of the ordinary?

Do you get the same result when using a browser window to hit

Do you have any proxies or are you on a VPN/Company network?

You could try using the Clear cache and Reload option to see if something is randomly being cached:

Good Morning @altimetry-cosmolog18 ,
I am able to use the curl command as well as the wget command on that url without http response errors. I believe the issue is somewhere else. You will find my screenshot below.


According to the documentation regarding the Day 27 in the 30 days of Postman for developers in step 4 you may set up an authorization whilst posting the request. You will receive in the response a bearer token that you reuse to post the same user.

In short, you create a new user through a bearer token authentication.

Thanks for the hints Danny! Turns out, I think it was my company VPN that was blocking the request. I switched to my personal laptop and it worked!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.