Could not open Postman

Thank’s. This action helped.

im getting the Could not open Postmanin windows 10. i tried deleted the postman folders above mentioned by @cyrielle. but still not able to open the postman tool . please help me to solve the issue

@sivababu2911 we put together a doc to better help our user base handle this issue better: https://support.getpostman.com/hc/en-us/articles/360025359014-How-to-resolve-the-Could-not-open-Postman-error-

@cyrielle after installing the postman in windows 10. the postman is not opening and i have reinstalled many times and doene rebooted the system as well. could you please help me and solve the issue.

Did you make sure to remove the local data in both locations?
C:\Users\<user>\AppData\Local\Postman and
C:\Users\<user>\AppData\Roaming\Postman

If this doesn’t work would you please try disabling your GPU?

If none of the above options work, please send us your logs so we can investigate further at help@getpostman.com and please refer to this thread.

Thx! It works good on Windows 10!

1 Like

Basically the first program with these stupid open issues. You can download a better written program from indian malware sites. Shame

The app did not open, however no error was thrown.
This is my first time using Postman, and I could very well be misusing the application.
However, I expect that opening an app… should open the app.

Here are the logs from the main.log file,

    [14911][1602036836785][main][info]["Booting PostmanAgent 0.2.1, darwin-19.6.0 on x64"]
    [14911][1602036836789][main][warn]["Postman Agent~Main~populateInstallationId: Failed to get installationId from agentSettings but with no error"]
    [14911][1602036836792][main][error]["InitHelper~createDefaultWorkingDir - Error while creating default working dir",{"name":"Error","message":"default working directory already exists","stack":"Error: default working directory already exists\n    at /Applications/Postman Agent.app/Contents/Resources/app/src/workingDir.js:21:23\n    at FSReqCallback.oncomplete (fs.js:166:5)"}]
    [14911][1602036836793][main][info]["UpdateHandler~init - Success"]
    [14911][1602036837499][main][info]["WebsocketAgent~start - Listening on port",10533]
    [14911][1602036837523][main][info]["AutoLaunch: Enabled"]
    [14911][1602036837526][main][info]["AutoLaunch: Enabled as the default behaviour."]
    [14911][1602036837554][main][info]["AutoLaunch: isAutoLaunchDefaultBehaviourSet is set and persisted."]
    [14911][1602036940519][main][info]["Quitting app"]

My settings.json:

{"installationId":"66ea4470-4d2f-4bec-b3aa-e430701f8edb","downloadedVersion":null,"isAutoLaunchDefaultBehaviourSet":true}

This is only a minor inconvenience because I will be using the website builder (until I am forced to revisit this issue due to browser limitations).
If I do find a resolution I will be sure to post here.

Hey @_Octal :wave:

Those logs indicate it’s from the Postman Agent, it’s a helper app to enable sending of requests using the Postman web app - Once you have the web-app open, select the “Desktop Agent” to send the request using the Postman Agent (Make sure it’s running).

Screen Shot 2020-10-07 at 3.37.11 PM

More details here: Announcing Postman for the Web, Now in Open Beta

Alternatively, download the Postman native app from here: https://www.postman.com/downloads/ :+1:

Cheers

love you <3333333333333333333333