Can't select file at form-data, "Make sure that Postman can read files inside the working directory."


I am trying to select my image but there is error. What i need to do to get this error away?

1 Like

@thedenhome: Hello, Welcome to the community!!

Can you check the location of the file? Else you would need to configure the working directory. Please refer

That error message makes me think you have a permissions issue.

If you open up settings (ctrl+,) and scroll to the bottom, where is the working directory pointed?

You might want to change it to a location that is public, if necessary.

2 Likes

Many thanks for this post.
I have the same problem!

I’m using Postman Agent on Windows
I’ve set the ‘working directory’ to be a path on my C: (Windows!).

When using Postman web and I select a file under that path I’ve specified, I get this error: “Make sure postman can read files inside the working directory”
image

I see that inside Postman web it shows the working directory to be “~/Postman/files”. This isn’t the same the same setting I see inside Postman on Windows. So where is this “~/Postman/files” folder on Windows? (I’ve tried lots of places, but none seem to work for me).

Should I understand that the web and the windows desktop are specifying the same working directory? (i.e. I can only have 1 working directory that is used by both?) Or is there a different working directory, one for the web, one for the desktop?

It would be nice for the Postman agent to say where it thinks its working directory is.

Many thanks for any suggestions, Matthew

1 Like

I worked it out! The folder is C:\Users\USERNAME\Postman\files
Not obvious at all.

2 Likes

Glad that worked! :slight_smile: Also for anyone facing similar issue, navigate to Settings and Toggle on the option “Allow reading files outside working directory” and that should help.

image

1 Like

Thank you,
Oddly I played with that setting ‘allow reading files outside working directory’ and, for me at least, it didn’t appear to make any difference. I’m using a Windows PC. Anyway, I’m pleased I got it to work :wink: Thanks again, Matthew

2 Likes

how i have the same issue??

Hi. I have the same problem. I don’t see any items when searching for files to upload in Postman Settings. I select path: C:\Users\USERNAME\Postman\files. But I see " No items match your search"

@zzaar123 Welcome to the Community!! :bouquet:

This field is only for folder selection. You can define your folder structure here. Incase you need to pass any file as input, and if you have already placed the file in this location you can just define the name alone.

Hi dear, My system is windows 10 ver 1903. My PostMan version is : Postman v8.0.10,
Today, I created a request for upload attachment, then it show me the tooltip:
“This file isn’t in your working directory. Teammates you share this request with won’t be able to use this file. To make collaboration easier you can setup your working directory in Settings.”
Now I Set the work directory to “C:\Users\Veary\Postman\files” and select a file in this directory, but it still doesn’t work, I set “Allow reading files outside working directory” is ON also.

My english is so terrible, Hope some one can help me.

Restart PostMan Done.
Restart System Done.

image

1 Like

Hey @Veary :wave:

Sorry to hear that you are experiencing this :slightly_frowning_face:

Are you seeing this issue on the web dashboard (go.postman.co) as well?

Please feel free to submit a support request from the following link :slightly_smiling_face:
https://support.postman.com/hc/en-us/requests/new

Dear taehoshino, much thanks.
There isn’t this issue on the web dashboard, only on the client, but I cann’t send a request, it show :" Cloud Agent Error: Can not send requests to localhost. Select a different agent.
Use Postman’s Desktop Agent
Learn more about troubleshooting API requests",
however, thank you for helping me :slightly_smiling_face:

Hey @Veary! Thanks for getting back to me :smiley:

So now you are seeing “Cloud Agent Error” while you are trying to send request to localhost, correct?

In that case, you can resolve the issue by downloading the Postman agent.
You can download the agent from the link below (scroll down a bit to " Desktop Agent " section):

And don’t forget to select “Desktop Agent” once installed.
Screen Shot 2021-04-01 at 2.30.49 pm

Hi
I have the same problem
I’m on a windows 10 machine

  1. the file is in the correct working directory
    2.post-man is set as desktop agent
    3.I turned on “Allow reading files outside working directory” but it didn’t make any difference
    4.I changed WorkingDirectory’s permissions to “everyone” but it did not help it.

I would appreciate any help

Solved

I installed the desktop client and got my work done but the web-based postman working with the postman agent didn’t work.

On windows 10 I turned on allow files from outside of working directory then renamed “C:/Users/username/Postman Agent” to “C:/Users/username/Postman” worked for me