Sudden Issue Updating - Win 11 - Solution

Hello everyone. Searched around and didn’t find anyone having this same sort of issue that I encountered and solved today so I thought I’d make a post about it. I hope this is the correct area to do so. Let me know if not, new guy around here.

Went to update Postman today and was given the same error in this troubleshooting page. Attempted the t-shoot methods however, none of them lined up with the errors I was experiencing. Then I thought to uninstall and install the update manually but this also did not work. In fact the uninstall just flat out did nothing at all, didn’t start. Then I attempted to uninstall via PowerShell but low and behold, PowerShell wont start! Saying that “mscoree.dll is missing”. Well I went down the rabbit hole of fixing PowerShell by “uninstalling”, re-installing, still broken and wont start. Then I found this page detailing some sort of bug that requires you go to optional programs and features then give three toggles the ol’ off and on again. And wouldn’t you know it, my .NET 3.5 was no longer checked. So something at some point randomly turned it off resulting in bunged up Postman updates and PowerShell failing to start.

Summary: If you find yourself getting update errors on Windows11 (and maybe 10) press Windows+R, put in optionalfeatures.exe then click OK. When optional features comes up make sure .NET 3.5 and .NET 4.8 are toggled on.

Hope this saves some people some time.

1 Like