Pull Changes and Merge Changes not working

Both myself and another team member have created a fork from a collection on a team workspace to our own private workspaces and have always been able to pull changes from and merge changes back to the team workspace collection. However, this past couple of days we’ve encountered issues whereby neither option completes. The screen simply shows the ‘busy’ animation and never moves on to completion:


I’ve even tried to simply merge changes, knowing that I don’t actually have any changes to pull, but even when I select the merge changes option, Postman again just shows the ‘busy’ animation, but never finishes.

The collection itself only has 20 requests, each of which are very small and only a couple of them have associated JavaScript scripts and even these are only a few lines long (no more than 20 lines). Again, the process worked well previously and we’ve no idea why it suddenly stopped working. We’re both using the same version of postman and have even tried updating the the latest release, v10.18.11, but it’s still not working. I’d really appreciate anyone’s help in getting this issue resolved.

1 Like

Hey @stephenkeenan :wave:

Welcome to the Postman community! :postman:

I spoke with the team regarding this issue, we have identified a potential problem and that is being actively worked on.

In the meantime, we have made some temporary changes that should now unblock you and the team. :heart:

Could you try working through that same flow to see if that is now working again? :pray:t2:

Hi Danny

Yes, it finally worked. Thank you.

1 Like

Hi Danny

I’ve been having the same issue the last few days as well. I’m on version v10.18.11 and this is happening for a specific forked collection. Is there anything I can try, or guidance someone can provide? Thank you.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.