Pull Changes and Merge Changes are not working

Myself and my team members have created a fork from a collection on a team workspace to our own private workspaces and have always been able to pull changes from and merge changes back to the team workspace collection.

From Friday onwards 10/May/2024 facing an issue that a loader is showing up

1 Like

me ocurre lo mismo, pueden ayudarnos

Hey @harithagoluguri / @satellite-candidate1 :wave:

Welcome to the Postman Community! :postman:

I’ve spoken to the team and there were a few spikes in traffic recently that may have caused issues in this area. In order to investigate further and track your specific Collections, would you be able to share the Collection Id, please?

You can get this by opening the Collection in a tab and navigating to the Info right sidebar option. The Id can be copied from there section.

Hey @harithagoluguri / @satellite-candidate1 :wave:

Also, if you could tried the flows again to see if the issues has been resolved (We’ve made a few changes on our side), that would be awesome. :pray:

Hey @harithagoluguri @satellite-candidate1, thanks for reporting the issue.

We are debugging this on priority. As the very first step and continuing on what @danny-dainton mentioned, we have made some changes in our servers, would you guys please refresh the app once and retry the merge/pull flow ? Let us know how it goes!

1 Like

Hello, I have tried again on the postman , i am still facing the same issue, even my team is also facing the same

@danny-dainton , Please find the collection details which we are trying to take the pull changes from 10204024-cb972966-82db-4f9e-a078-f1d2661ccd2d


@harithagoluguri i can see there are no actual calls made to pull changes to/from this collection. That means the loader that you are seeing is maybe while loading the diff or some flow before actual pull. Could you verify this once and if possible do share a small recording with us. That would be helpful to reproduce the same issue at our end. :pray:

Hello ,
We have taken multiple forks from this collection, when i am trying to pull changes , loader is keep on showing, PFA , It is not allowing me to attach the video recording , hence attached the screenshots

1 Like

Thanks for confirming this @harithagoluguri. The issue seems to be more specific to a particular aspect of the shared collection and is not happening for every pull. We are working on priority to fix this and will notify you here once done. Thanks for helping out with the screenshots. :pray:

1 Like

Hey @harithagoluguri, we have fixed the issue on our servers and verify at our end. Could you retry the pull/merge flow once and do let us know if it works ?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.