Proxy Session won't start

I’m using the latest version of Postman, and after creating a Workspace and Collection, after clicking on Start Proxy and then Start Proxy Session, I can’t seem to enable the proxy.

There’s an orange button saying “Start Proxy Session” but the session simply does not start. After clicking on it, everything stays the same, the button is still there, the proxy is not started and I can’t seem to understand how to fix this. Any ideas?

Also, I already tried lots of different ports, but that didn’t resolve the issue…

Hi @fssecur3 !

Sorry to see you are running into an issue like this :confused:
Let’s see if we can get this sorted out!

Here are some steps and troubleshooting tips to potentially resolve this issue:

  1. Check System-Wide Proxy Settings:
  • Ensure no other application or system-wide setting is using the proxy port you are trying to set in Postman. Some other software might be using that port, preventing Postman from starting its proxy. This seems to typically be the #1 issue I’ve seen like this.
  1. Restart Postman:
  • Simply close Postman completely and reopen it. Sometimes, applications need a fresh start to function properly after changes.
  1. Logs and Console:
  • Check Postman’s console for any related error messages. This can give clues if something is going wrong.
  1. Permissions:
  • Ensure that Postman has the necessary permissions on your system, especially if you’re using macOS or Linux. Some actions might require elevated privileges.
  1. Update or Reinstall:
  • You mentioned you’re using the latest version, but it might be worth checking for updates anyway. If you’re already on the latest version, consider reinstalling Postman. Sometimes, files get corrupted, and a fresh install can fix the issue.
  1. Network Security Software:
  • Some network security software or firewalls might prevent Postman from starting a proxy session. Ensure any security software you have isn’t blocking Postman.
  1. Reach out to Postman’s Official Support:
  • If none of the above solutions work, it would be a good idea to reach out to Postman support by opening a ticket.

I hope this helps! :slight_smile:

Well, regarding those tips:

  1. I tried multiple ports (555*, 1000*, etc.), none of them being used (verified with netstat), I checked my tools’ proxies - such as Burp Suite or OWASP ZAP.

  2. Restarting was no good to the issue, still the same.

  3. Nothing appears in the console, from any log.

  4. I’m using Windows, I tried with and without Administrator permissions.

  5. Reinstalled, still the same issue.

  6. I have no software that prevents Postman from starting a proxy session.

  7. This might be the way then…

Thanks for the help, anyway!

1 Like

Please do update us when you have a resolution! May be helpful for others experiencing a similar issue :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.