Tunneling socket could no be established

I’m trying to use postman desktop app to POST to a REST API. I’m in a corporate environment. There is a proxy configured in Internet Options.
I have tried using the System Proxy, but it times out.
I have also tried configuring it manually with Proxy Auth. However I get: “Could not get any response”. I tried it with the SSL option off and on.
If I look at Postman Console I see "Error: tunneling socket could not be established, cause=getaddrinfo ENOTFOUND [snip]’.
If I try disable the Proxy Auth, then I get a 407 Proxy authentication required response.

I then tried Soap UI and used Automatic settings with credentials and it works.

Hi @camios,

Sounds like an interesting issue. I have not worked too much with the proxy in Postman, however I am pretty familiar with proxies in general and should be able to assist.

It looks like somehow within Postman it cannot reach the proxy. By default, are you connected to the proxy in your System settings? If so, you should not need to put the proxy in there.

If not, you may need to do some testing and work with your IT department on helping resolve the issue you are having.

I would ask for screenshots of your proxy configuration in Postman, however knowing you are in a corporate environment, I understand that you may not be able to.


My OS Settings for Internet Options has a proxy.
However Postman seems to ignore the setting or Postman has bug. Here’s what I’ve tried:

  • I’ve setup Postman to enable System proxy
  • Alternatively I’ve tried manually configuring the same proxy in Postman’s Global proxy and enabled it, same problem.
  • I’ve tried disabling both proxy settings in postman.
  • I’ve tried enabling both proxy settings in postman.
  • I’ve tried using a batch file with HTTP_PROXY environment variables to launch postman and it still has the same problem.
    So I’ve raised a support ticket. They’ve suggested it is getting to the proxy when I use Global settings, but there’s a dns error but it seems to be a dns error on my AD domain part of my user name. I’ll check with them what the syntax should be.

Thanks for the details.

It’s possible there is a bug, however I have not tried it out. I do have a proxy set up so I can try it once I get a chance.

However, you have done a good amount of troubleshooting that I would do. Thats quite an interesting error to receive. Can you try with just the IP Address to get around the DNS?

Additionally, if that doesnt work, it could be a firewall issue. I would suggest reaching out to your networking team to see if the see this request being blocked. With “Next Generation” Firewalls, they can block applications from using certain protocols, not just on the port level, so its possible that postman is recognized as an application and its being blocked because it doesnt match the existing rule.

I would also suggest recording your network traffic with wireshark while you try to connect. Then collect that pcap and review whats happening, or also send it to you networking team to see what they have to say.

I will let you know if I run into any issues with using my proxy on the most current version of postman.


I cannot use postman on my laptop. I either get 403 or 404 errors. Not sure how to troubleshoot as I have tried everything pertaining to a proxy. Fiddler works just fine. Can you help?
“Tunneling socket could not be established, statusCode=404”

@attorneygenender 404 suggests that you’re entering an incorrect URL. Are you using the Postman app or Postman in your browser?