Postman desktop keeps crashing on mac

My question: Hi, Postman keeps crashing on desktop.

How I found the problem: Send request, receiving somewhat large response.

I’ve already tried: Reinstalling postman.

In main.log found an error:

[36362][1680022465609][main][error]["Main~handleUncaughtError - Uncaught errors",{"name":"Error","message":"Render frame was disposed before WebFrameMain could be accessed","stack":"Error: Render frame was disposed before WebFrameMain could be accessed\n    at decirc (/Applications/\n    at decirc (/Applications/\n    at decirc (/Applications/\n    at decirc (/Applications/\n    at decirc (/Applications/\n    at stringify (/Applications/\n    at Format.transform (/Applications/\n    at DerivedLogger._transform (/Applications/\n    at DerivedLogger.Transform._read (/Applications/\n    at DerivedLogger.Transform._write (/Applications/\n    at doWrite (/Applications/\n    at writeOrBuffer (/Applications/\n    at DerivedLogger.Writable.write (/Applications/\n    at DerivedLogger.log (/Applications/\n    at /Applications/\n    at Array.forEach (<anonymous>)"}]
1 Like

I am having the same issue. Postman v10.13.4 just quits unexpectedly. Anyone been able to find a solution?

I had the same issue but I’ve finally fixed it.
To fix it, follow the following steps.
Locate your postman folder:

  1. Open finder.
  2. go to ~/Library/Application Support

find the postman folder, rename it to something like postman old.
then restart your postman.

if you feel any data is missing, copy the contents of the renamed postman folder into the newly created postman folder.
Hope this helps.

I tried this but it didn’t work for me. Did you reinstall postman after renaming the folder? (My version is 10.13.4 and I have a macbook with M1 Pro)

In my main.log I have this error:
[44999][1682347227004][main][error][“Main~handleUncaughtError - Uncaught errors”,{“name”:“TypeError”,“message”:“Cannot read properties of undefined (reading ‘isServer’)”,“stack”:“TypeError: Cannot read properties of undefined (reading ‘isServer’)\n at TLSWrap.onerror (node:_tls_wrap:411:27)”}]

I’ve downgraded to version 9.31.27 and it’s not crashing anymore for me. I will stay in this version until this issue is fixed.