Postman 8.0.6. can't remember history

Hey guys,
Thanks for your great piece of software.
Unfortunately since the 8.0.6 upgrade things don’t seem to be going that great anymore. Postman seems to keep the history in the cloud (which is not a bad thing), but it can’t retrieve it from there.
“We couldn’t fetch your request due to some unforeseen circumstances. Try again.” I’ve tried quite some things (e.g. stopping the firewall, waiting for a couple of days).
Where can I find official version 7.x
Thanks.

Hey @hovsepyan.aram,
Welcome to the Postman community :rocket:

Sorry for the hassle, but happy to help!
I understand you are seeing an error on the native app and unable to see History.
It sounds like a web-socket network issue but you have already tried stopping the firewall.
Do you see the same issue on the web dashboard (go.postman.co)?

Apart from firewall, if you are using proxy/VPN/antivirus applications, please whitelist the following domains to allow web-socket connection:

*.getpostman.com
*.postman.co
*.pstmn.io
*postman.com

To get you unblocked, you can download the latest v7 from the following link:
macOS: https://go.pstmn.io/dl-macos64-v7-latest
Windows 64-bit: https://go.pstmn.io/dl-win64-v7-latest
Linux 64-bit: https://go.pstmn.io/dl-linux64-v7-latest

However, if you need further assistance, please feel free to reach out to our support from this link.
We’d be more than happy to assist you :slightly_smiling_face:

Hey Tae,

I did try disabling firewall indeed. I think version 7 is good for now.
Thanks a lot.

Thanks for getting back @hovsepyan.aram!

Please feel free to reach out to us if there is anything else we can help!

Have a nice weekend :wink:

I have this same issue. I upgraded to Postman 8 a few weeks ago (current version 8.0.7).

I have several personal workspaces for different projects. In those workspaces, I had several tabs open for different kinds of calls. I haven’t used Postman for a couple of weeks now, but last time I was in Postman they worked.

Today I opened Postman and when I switched to the workspace, I suddenly get a bunch (one for each open tab) of pop-up error message on the right side of the Postman window each saying “Could not find the request you are looking for.” Then the main window for each tab simply displays, “Something went wrong. We couldn’t fetch your request due to some unforeseen circumstances.”

Note, these are personal workspaces, not cloud “team” workspaces.

Taking a tip from the earlier post, if I go to go.postman.co, I do see my workspaces there, but none of the workspaces have any of the tabs that I had open in the local client.

Firewall shouldn’t be an issue. I had these tabs IN version 8 a few weeks ago. If it were a firewall issue I think I would have had an issue right away after installing version 8.

If I revert to version 7, will I get my tabs back, or are they lost? Wouldn’t i have to uninstall 8 to then reinstall 7? Can it somehow preserver the tabs between the 8 uninstall and 7 reinstall?

I had a LOT of open tabs for a particular project with various customizations. That’s a lot of lost work if I have to start over from scratch on it. I do have a collection as the base to start over from, but I had lots of customizations in the tabs while I was still tweaking things before finalizing.

Postman 7 has issues with rendering some beautified dump outputs while debugging. So I’m back to square one. Postman 8 works fine in scratchpad mode. But it would be nice to have it working properly.
I have once again checked firewall settings. I am running an OSX Big Sur with nothing outside the box in terms of security and firewall.

I am having the same issue. Is this going to be fixed any time soon? I tried switching to the version 7, but all my tabs have disappeared from all my workspaces. And, worse than that, any changes that I had in my workspaces but hadn’t saved into collections have disappeared. I really want my data back. This isn’t just a connectivity issue: data seems to be getting lost.

Following from my previous post,

I went ahead and tried this anyway. I was able to reinstall 7 over 8 without needing to uninstall 8 first. I didn’t get my tabs back, but I at least had my history that I was able to go through and recreate tabs from.

For me the problem is now solved since Postman 8.0.7.

My problem was WITH 8.0.7.

I’m suddenly getting this on 8.0.7 after restarting my laptop. No other network changes etc. – any fixes?