Galaxy API Adoption final test collection

Im still failing on this final step i made all the correct steps updating the workspace value from headers in my test collection request and then copy my public link in the request address and click send but it still faills if someone can help with me, I will appreciate
Evidence:
And this how my request looks like

Hi @JoseLedezma welcome to the community :slight_smile:

Have you solved this issue?

If not the point you are missing here is instead of giving the workspace url you have provide the collection public link, change that and it should work :slight_smile:

Thanks a lot Jency. That helped me a lot. I was using the wrong workspace url

1 Like

@jency.stella19 Thanks for your answer this helped me as well

1 Like

Dear all,
I have the same issue. However I fill in the right workspace value. Would you mind checking my collection ?

https://www.getpostman.com/collections/05cb069e801461d32ea4

Regards,
Malkico60

Note the above issue has been solved in a related thread:

Thank you very much. :blush:

@neilstudd @jency.stella19 @ibrahimjassat @JoseLedezma @malkico60 @JoseLedezma

Hoping that someone can assist me on this…Thanks in advance.

One of the final test is failing and error is:

Published workspace (included in Headers ‘workspace’ param) | AssertionError: expected ‘’ to have a length above 0 but got 0

//published workspace
pm.test(“Published workspace (included in Headers ‘workspace’ param)”, () => {
let params=pm.response.json().item[1].item[1].request.header[0];
//console.log( Print for test: ${params} );
pm.expect(params.value).to.have.length.greaterThan(0);
pm.expect(params.value).to.contain(‘postman.com’);
pm.expect(params.value).to.contain(’/workspace’);
});

Any feedback would be appreciated. Also, can someone send me the sample of the workspace link?

I understand that the test is for:
pm.response.json().item[1].item[1].request.header[0];

So, when I printed: console.log(pm.response.json().item[1]);

{
name: “Complete submission”
item: [2]
id: “19f907be-84f4-4b69-899a-fc9c5576c092”
description: "Complete your submission for the Galaxy API Adoption badge using the two requests in this final folder:

This means that item: [1] is not even coming in the response. but I am not sure why?

Hi.

I keep on getting an error on the final test Test Collection request. It seems that the response data keeps on returning as an HTML format instead of JSON. I have followed all the steps for all the requests and have reviewed each of them several times.

I have also made my profile and the workspace public per the publish instruction. I believe the workspace URL and collection URL were also added appropriately but I really can’t figure out what is wrong or missing and I hope someone could point it out.

These are the links I have added in the final steps.

workspace = https://www.postman.com/randyroman-qa-team/workspace/public-workspace

request URL (collection) = https://www.postman.com/randyroman-qa-team/workspace/public-workspace/collection/18313954-7632bad0-4ce0-4dc9-ac66-ca5203845f82

Hi! Don’t worry, you’ve done nothing wrong. There was an outage at Glitch yesterday, which is where the server for this training is hosted.

Glitch is back online now, so please try again!

Hi clairefro.

I tried again just now I am still getting the same error. :frowning:

There was an error in evaluating the test script: JSONError: Unexpected token ‘<’ at 1:1 ^

Can you please check the “Preview” tab of the response and share the output? This will be the rendered HTML of the response if there is some kind of error coming from the server

Hi. There is nothing being rendered in the “Preview” tab. Below is the output of “Visualize” tab if it helps:

Hmm this seems to be HTML and not JSON - you might have hit an invalid endpoint - undo your changes, or close the request without saving and try opening / sending it again!

I’m not able to attach or include the full response here as it is exceeding the maximum characters. But below is the main body: (w/o the block)

Postman

Strange - the server is working so there must be something funky with the request. Have you tried troubleshooting these things:

  • Make sure you are using a valid Postman API key
  • Make sure you are using a valid collectionId (from the (i) icon on the right when you click on the Collection folder. Make sure you are not using a request ID)
  • Re-read the instructions and ensure you are passing all parameters correctly

I finally figured it out. :smiley: I incorrectly used a Collection link which I copied using the share “Via Workspace” option.

The correct collection link should be taken using the share “Via JSON link” option.

Thank you for your patience and help. :slight_smile:

how can i learn my workspace url?

Hey there!
To get your workspace URL, try opening your workspace in a web browser. It should look something like this: https://www.postman.com/postman/workspace/f21c2968-b83d-485e-9360-21fc4de72be3/overview

thanks a lot. i solved my problem

@randyroman
Hey Randy,
I am Deviprasad, am at the final step of submitting the test collection I see you were able to submit the collection successfully with a few modifications.
I am getting the same error as above, have copied the collection URL from Via JSON Link and provided the workspace variable.

Publick Workspace: Postman
Collection:https://www.getpostman.com/collections/9ad1b27c6eb25a9edf1c

@neilstudd @jency.stella19 @ibrahimjassat @JoseLedezma @malkico60 @JoseLedezma

Adding the entire crew, hoping someone can assist.

Thanks in advance

Hi. Just basing on the screenshot you provided, it seems that you have an AssertionError in one of your tests. Looks like the URL is having a mismatch with the substring “postman.co” vs “postman.com