Getting the following error during the GALAXY API ADOPTION TRAINING

Got this error while changing value for workspace key in headers and changing address to collections link
My workspace is public and collection link is also correct. Any idea on how to solve this?

Hey @smritinahata305,
Firstly, great job! You’re almost there :grinning:
Could you post the link to your public workspace, that would certainly help debug the issue?

I had the same error can someone help me? follow my link : https://www.getpostman.com/collections/5227d5174d81997f9f7a

Hi @gallaodev,

It looks like this should be an easy problem to fix. The problem is with the header that you have added in the Test collection request:

There are two issues here:

  1. There is a typo in the key name: you have called it woakspace when it should be workspace
  2. You’ve set the value to your collection link, but the exercise says that you should enter your workspace link. For example, mine is: https://www.postman.com/MY-TEAM-NAME/workspace/MY-WORKSPACE-NAME/overview

If you reformat that header key/value to match this, your test should pass.

1 Like

Thank you @neilstudd, work now.

I didn’t understand that it was necessary to update the get public link, I thought it was automatic, so the key was wrong in the post, I had corrected it but I didn’t update it.

I didn’t really pay attention to the phrase: Add the URL for your public workspace, tks again.

Dear all,
I am stuck on the same error but I used the proper workspace link. Would you mind checking my collection?
https://www.getpostman.com/collections/05cb069e801461d32ea4
Regards,

@malkico60 Welcome to the Community :partying_face:

  1. Please don’t save the workspace as a variable.

image

Something like this,

Because your Test is validating the URL here.

  1. For Test collection request, you need to only pass the collection link.

I hope this helps :smiley:

Please let us know if you still face any issues here :blush:

3 Likes

Thank you for your tips. There were useful.

2 Likes