ENV Variables are not cloned on Windows from URL

Hello

I’m a software engineer from Backendless and we’ve got integration with Postman. So our customers able to click the button “Run API in Postman” and export our API Collection along with ENV variables of the selected application through a link.
And it works well for a long time at least on OSX, however, we noticed it doesn’t work on Windows OS, ENV variables are not cloned in Postman namespace as expected.

Could you please help me figure out what we can do from our side or maybe you can check this feature on your side for Windows.

Anyways, here is a link which works properly for Mac:

https://app.getpostman.com/run-collection/f2948e8fc13ee57ec71a?#?env%5BBackendless%20App%20%22postman_demo%22%5D%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%3D%3D

Thanks in advance for any advice.
Regards, Vlad

Hello @subramanya.raj

Could you please help me with that?

Regards, Vlad

Hi @vladimir.upirov

Welcome to the community :wave:

I tried importing the collection and see that the environments such as “Data Object ID” or “Geopoint ID” do not have initial nor current values. If I understand this properly, some of the environment variables end up being empty while you click on “Run in Postman”? correct me if I am wrong.

If this is not the issue, could you point me out to the exact issue and I will check on this further.

Thank you for your quick replay, I really appreciate that.

Yeah, these variables must be empty right after cloning.
However can you see the Backendless App "postman_demo" ENV and vars such as AppID, APIKey, etc.?

the following screenshot is made using app on MacOS:

Regards, Vlad

1 Like

Yes! I am able to see the environments on the Mac system - let me get hold of a Windows system and test this out quickly. Meanwhile, few things that we can try if the issue persists, is to check - if you are able to see the same environments from the Web dashboard: https://go.postman.co/me/environments

If yes, the values are synced across web-dashboard and all of the users should be able to see them. I am assuming you have published this collection as documentation - If yes, could you try to unpublish the documentation and then re-publish the same by selecting this environment and see if that resolves this?

Note: the documentation link will re-generate and no longer remain the same once re-published.

If you’ve used Embed link - could you try updating the same and see if that works?

@subramanya.raj, I confirm that it is not working for me either on Windows, but works on Mac OSX. It appears the environment import into the Widows version of Postman is broken.

Were you able to verify it on your end?

Mark

1 Like

Hello @subramanya.raj

Sorry for the delay.
Seems it doesn’t work on Linux OS either, could you please confirm that?
Is there any way to reach the same behaviour on Windows/Linux as on MacOS?
Maybe there is any workaround for that.

Regards, Vlad

1 Like

@mpiller @vladimir.upirov Hey, I tried it on a Linux machine and there appeared to be importing issue in it - would it be possible for you to submit a ticket from the below link and to check on this further: https://support.getpostman.com/hc/en-us/requests/new

Done!

Request ID is #50177

1 Like

Thank you - have received the same :handshake: