Postman v10,postmanCLI execution of folder not picking environement variable

My Postman request

Here is my CLI Command

postman login --with-api-key
postman collection run 22942095-90a9a1e6-c1a3-4a81-ab5c-1b85fbffde94 -e 22942095-c64a7fe4-3150-4dc3-b798-e743bd89631d -i 22942095-ce474db4-81bf-4f97-9d75-818313cc39fe

the command included -e with the parameter. However, in execution, it’s not picking BaseURL comes from Environment variables

Hi @Veenadevi
Looking at that screenshot, it doesn’t pick up the other variable either.
Are you sure that the collection and environment UIDs you are using are correct?

I just tried it myself using a basic example and it works…

Yes , I am using correct UID of my Environment. If I pass as Environment variable for single value its taking

–env-var "BaseURL=“” .However not picking directly from UID .Cross verified with

Still not picking

Hi @Veenadevi :wave:

It seems your initial value of the environment variable is empty because of which Postman CLI is picking up empty value for your variable.

Postman CLI relies on the initial values of your variables that is stored in Postman. The current values are like session values and we do not store them on our Db.
Read more about initial and current values of variable here: Using variables | Postman Learning Center

Hope this helps solves your problem.


1 Like

Thanks @supply-administrato3 …Its Solved my issue

1 Like