Collection Request documentation not saving in all cases

I have spent hours adding some response documentation for requests in a collection. After creating quite a few requests with very large response bodies in JSON I have found that going back to the documentation shows that my changes are not being saved. I have lost a lot of time on this issue. The general steps I have been following:

  • Create a new request and configure the parameters, url, body, etc.
  • Go to the Documentation tab and put in a description.
  • Save the request.
  • Now use VSCode to create the formatted JSON body of the response that I expect. (It’s easier than using Postman)
  • Go back to the documentation section of the request and start the code block.
  • Select JSON as the language.
  • Paste in the JSON from VSCode.
  • Close the documentation .
  • Open the documentation back up and notice it didn’t save it.
  • Repeat the process of adding the JSON response sample.
  • This time click outside the code block after pasting.
  • Now close the documentation tab.
  • Open and it generally has saved it but I cannot confirm that it does in all cases.

Hey @mtaylor :wave:

Welcome to the Postman Community! :postman:

You could try enabling the the Autosave feature from the ⚙️ > Settings > General menu, that would at the very least save changes made to the Collections and Requests.

If this problem does continue to persist, could I ask that you raise a new issue for it over on our issue tracker please? :pray:

Autosave is not really an option here as we don’t want arbitrary changes saved automatically. We just want the documentation saved correctly. I’ll submit an issue.

The autosave option was more about showing that there is that option available to you. :pray:

I’ve followed your steps and it seems to be saving the documentation each and I’ve tried a number of different variations too. :cry:

As you mentioned, it’s intermittent or it doesn’t happen in all cases so it’s just a matter of narrowing down the steps to reproduce the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.