Can not login on desktop app on Ubuntu

Hi

I can’t login into Postman Desktop (Postman v9.31.30) on Ubuntu.

  1. Logout of postman.com website (just in case there was any issues with multi-sign in)

  2. Install a fresh copy of Postman

  3. Open the app (I’m confronted with a blank Postman profile and an option to sign-in

  4. Click Signin button and a new window with a spinning solar-system loading graphic shows. Waiting there for more than 15 minutes I have no option but to click the “Skip and take me to Postman Desktop App” where I can only see the blank unlogged profile with the Signin button.

  5. Logging back into the website and repeating these steps did not work either as I also thought that perhaps it would help to be logged in on the website too.

  • I’ve completely uninstalled and reinstalled dozens of times by this point trying to get it to login.
  • Whether I’m using a VPN or not makes no difference (tried both)
  • Also tried multiple reboots.
  • All OS updates are applied no other sign-in issues across other apps.

Interesting, when I download and install on my Windows PC (not installed it there before so completely fresh first time install) I see the same screen with the spinning solar system except that there is now a weird horrible overlay asking to verify me as human (tick some box). I’ve not see this appear on Ubuntu so perhaps this is unsupported/not correctly implemented and the cause of the issue of why it is hanging on this screen.

Update: seems to be related to this “human authorisation” checkpoint. Someone else confirmed that this pops up on PopOS and allows them to sign-in but my environment just does not show this check and hangs. I’m not sure if there’s a missing package but I’ve got no way of knowing what dependency I need to install manually either (something I thought would happen when the app was installed)

I downloaded the Postman directly from the link and it worked first time after running it manually (not via Snap manager).

I’ve booted up this morning to find that Snap manager has now updated with the latest release (it was previously providing v9.31.30 but now is installing v11.2.0)

Hi @zombiesbyte. Welcome to the Postman Community :postman:.

I’m sorry you’re experiencing this. I’m not sure what the issue could be, but someone from our support team might be able to offer you better assistance. Do you mind sending your request here over to help@postman.com?