Anonymous user displayed in Personal Workspace

Hello, everyone.

My question:

I have a Personal Workspace that I use, and I’ve recently had an anonymous user appear in that Personal Workspace.
Here’s what that looked like:

I’m sure that the Workspace is indeed configured as Personal (my account isn’t even public).
I’ve never sent out any invitations to this Workspace, nor made it Public at any point.

There is no trace left of this user (if it indeed was an actual user) in the form of Workspace Activity, and the Workspace still displays only my account as the sole contributor.


I am using Postman for Windows, Version 9.13.1.
I only use the Desktop app. I do not use the Postman browser app.

How I found the problem:

I encountered the problem by chance: my Postman Desktop app was open, but minimized and not being used. On maximizing the window, I saw the little anonymous user icon. On restarting the Desktop app, the icon was gone.

I will note here that my work includes VPN use, and I’m often connecting to and disconnecting from these networks. Establishing and breaking the connections may have the effect of me losing Internet connection briefly - I’ve even noticed Postman’s server sync indicator reflect this, as it goes grey and changes appropriately when the connection is broken, and then transitions to yellow and green again a few seconds later, when it’s established again.

I’ve already tried:

I’ve tried replicating the issue through establishing and breaking VPN connections, or disconnecting from with Internet with Postman running, and observing the results when re-establishing the connection, but I’ve had no luck with making the anonymous user reappear.
As far as I can tell, the issue has not occurred past the one incident.

I’m wondering if anyone’s had an experience similar to mine or could shed some light on the matter.

More specifically, I’m hoping someone could maybe confirm my suspicions that it was the breaking and re-establishing of my Internet connection with Postman idling in the background that caused the problem. Seeing how these re-connections trigger synching, could it be that something went wrong during that process, and that somehow a previous session of mine was not recognized by Postman as my own, and instead displayed as “Anonymous Andromeda” (as far as I can tell, this is the default way that Postman renders the first user in a Workspace that it identifies as “not you”).

Lastly, I’ll admit I’m also hoping this could help placate my (perhaps unfounded) fears of this being an indication of unwanted remote access, which is why I’m wondering how Postman handles these (sometimes frequent) re-connections, and if it could simply be a UI bug.
I don’t have any other reasons to suspect malicious activity from the outside, especially given the fact that I’m on the more careful and conservative side when it comes to my Internet activity.
Still, seeing an “anonymous” in a Personal Workspace raised a particularly uncomfortable kind of red flag, so I figured it was worth a check here.

Thanks all.