Variables are not posting

Any idea why it might be doing this? I have the {{var}} set correctly, and the authorization is correct, but when i execute the command it spits back that it is an Invalid URI “https:///api/v1/system/licensing” if i put the full IP address in “” it works fine. Any ideas?


I tried hitting your URL, getting time out error, may be I am missing something in the body. But I think I found the issue.

I tried using two variables A and B

Make sure that the current value is also assigned to the environmental variable you are using and try hitting it again.

If it doesn’t help please check the values assigned for the variables.

I hope this works :slight_smile:

you won’t be able to hit the correct IP address, is bogus (it was there to say it was there). The real IP is also not a public IP, so you won’t be able to hit it either. Postman acts as if there isn’t a variable, but there is.

Hey @tormenteddave - welcome to the community :wave:

I saw that the “Current” value is empty for the variable apiport in the initial screenshot that you had posted. That’s the value that would be used when you run the request. Copy the “Initial” value over to “Current” field and things should work as expected :+1:

Quoting from:

  • The Initial Value is synced to your account via the Postman servers and shared with any collaborators who have access to the environment.
  • The Current Value is local to your Postman app, and is never synced to your account or shared with your team— unless you choose to persist it .

To update the synced variable with your local value, set the initial value to the current value by clicking to the right of the variable row and choosing Persist . To reset your local (current) value with the synced value shared with your workspace / collaborators, click Reset . You can persist or reset all values in the environment using Persist All and Reset All .

That worked! Thank you!

1 Like