Read Only Mode Unable to make changes in the body of a request

Unable to make changes in the body as “Read Only Mode” , but my account is verified


Hey @Admin39

Are you sure you’re not trying the edit the response body here - It’s difficult to tell from that image.

Could you post an image of the full app screen?

Hello Danny

Big picture we have a default Cloudflare zone and when I run “GET” command and see these ciphers in this zone. We need to duplicate these ciphers for the zone at the bottom.

We need to run a patch request to add the above ciphers to this zone. Any idea how to input this info


I’d imagine that you when need to create a new request, either a POST, PATCH or PUT containing the relevant details.
The details would need to go in the request body.

I don’t know the full details of the endpoint that you’re hitting I wouldn’t know what that looks like.

The original question though, from looking at the image, you were trying to edit the response body of the GET request. Thay why you would see that tooltip as it’s a non editable field.

Even when I have a put request selected. I still see the message. Ideally I’s like to copy the request from the proper zone to this one

I don’t really understand what you mean by ‘zones’ as I don’t know how to use the cloudflare API - you’re going to see that tool tip each time you try and edit the response body like that. It’s non editable.

A PUT request would require you to add the data you want to send, to the request body and potentially use a slightly different URL.

Are you following some documentation?
Does it contain some examples requests to do certain actions?

Can you share that so people can see what the request should look like and offer some pointers.

We are using Cloudflare. We currently we have one account/zone that has our company standard ciphers. We recently created some new zones in Cloudflare and need to add these standard ciphers to those new zones. There are two docs I’m using mind you I have never done this before and new to postman. I would like to copy and past these detail into a patch request body but I get the “read only” message. But in the postman documentation I do not see a PATCH or GET command for ciphers. Not sure if the headers section is the proper location for the ciphers. I have tried to copy the cipher settings from the valid zone in the body of the request, but get “read only” message. Upon research I hear that this could be caused by email not being activated. I have confirmed my email activated.

Below I copied the request from our current zone with the headers, but when I try to paste in the body using patch request. I see the below error

You don’t have a request body selected for the PATCH request - you need to select raw > JSON and then paste the request body in there.

What you’re doing is selecting the response body from the previous request. That’s already happened. All you can do with that is copy it and place in to a different request body.

The tooltip you’re seeing has nothing to do with the response you see from the cloudflare request you made, it will do the same for any request you make.

An even easier way to know the format of the request is to copy the Curl command from the documentation, select Import in the top left of the Postman app, open the raw text tab and paste the command.

Once imported, it will create a new PATCH request for you to use.

Yeah…………I just realized what I was doing wrong after watching a video, I was able to make the needed update. I really appreciate the time and help.


1 Like