Postman hangs on startup

Hi. I’m new to Postman, and just trying to get it up and running. I’ve created an account and installed the software (64-bit version) on a Windows Server 2012 R2 VM.

I can get as far as entering my user ID and password, but then it hangs on the splash screen, where it says “Preparing your workspaces. This might take a few minutes.” (I went as far as leaving it there overnight, so I know it’s not just that I’m not giving it enough time.)

In searching this forum and Github, I found this issue which seemed like it migh be relevant. I’ve tried a few things from that issue and from other places, but I still can’t get it to work.

Stuff I’ve tried:

  • setting environment variable POSTMAN_DISABLE_GPU=true.
  • wiping out the appdata/roaming/postman folder.
  • replacing child permissions in the appdata/roaming/postman folder.

Here are the current messages I get if I launch Postman from the command prompt:

Disabling GPU
(node:9704) [DEP0061] DeprecationWarning: fs.SyncWriteStream is deprecated.
Main~createDefaultWorkingDir - Default working dir creation already attempted
1563476008226 main info "Booting Postman 7.2.2, win32-6.3.9600 on x64"
1563476008226 main info "EventBus~initialize - Success"
1563476008226 main info "UpdateHandler~init - Success"
1563476008226 main info "RuntimeExecutionService~initialized: Success"
1563476008226 main info "ProtocolHandler~init - Success with status: true]"
1563476008351 main info "PluginHost~bootHost: Booted - 1"
1563476008509 main info "Bootstrap-models~bootstrap - Success"
1563476010440 main info "PluginHost~bootHost: Booted - 2"

I’m not sure what else to try. If anyone has any hints, please let me know. Thanks!

1 Like

Hi @ahueyshi

Can you try clearing the local cache here which might fix the issue?

To remove your local data, delete the Postman folder at the following locations

Open File Explorer and paste in the Path field
C:\Users\<user>\AppData\Roaming\Postman ​ and

If you have multiple versions of the app installed, please make sure to remove them before reinstalling the app. If the issue persists, please collect the logs as per this article here and send them to

1 Like