Postman Collection is not updated

Hey,
i have Postman test which is sending a file to remote server.
I’ve changed the file
Running tests one by one, tests pass
Attempting to send as a collection - Seems that Post test doesn’t do anything
(and Get Fail)
How can i refresh the values in collection?

Hey @JuliaKaplan

Welcome to the community :wave:t2:

After making changes to the requests, are you saving these before using the runner? If any of the tabs in the Collection had an orange dot on them, then have unsaved changes and the runner wouldn’t pick these up.

All saved. No orange dots :frowning: Runner still not updated
tried closing and opening again
even restart the computer :slight_smile:

Are you able to share some images of the app that you can see, please?

It’s quite difficult to know what’s going on without seeing it. :smiley:

Are there any errors in the Postman Console? Can you check to see what is actually sent in those POST Request and see any differences between the 2.

Are you using any variables in the request, anything specific about the file that could be important?

The more context and detail that you can provide, the easier it will be to get to a solution :trophy:

Chiming in to let you know that I’m moving this topic over to “help” – so that others can see the solutions as well. :trophy:

This is the POST Request:


Running just this test, the document is sent and i get RequestID
image
Running Get request after i get a result

Running the same Post and Get using Collection runner
The document is not set to DB

Thanks for sharing the images - You might need to include the whole app in the image as there are different parts that could be impacting the request in the runner, the cropped image wouldn’t show this.

What does the ‘good’ request look like in the Postman Console?

The runner request is returning a 400 Bad Request code so it’s something that’s in the request that isn’t quite right.

You can open the console from the bottom left of the app:

You can do the same thing from the Runner - Send both requests and compare the differences to see if there is something in there that doesn’t look quite right.

The issue was the folder source file was located.
Moving the files to another directory fixed it
Thank you for helping me solve this!!
Have a great day
@dannydainton

1 Like