Postman API - GET environments request error

I recently added a new environment in a workspace. Using the postman api, I’m trying to get the UID of the newly created environment but I keep getting below error when sending a GET request to https://api.getpostman.com/environments:

{
“error”: {
“name”: “syncError”,
“message”: “Input parameters are not valid.”
}
}


This used to work without a problem, but last week it stopped working.
I can still get all collections and their UID’s without a problem.
Getting a single environment also still works (for example: GET - https://api.getpostman.com/environments/11749703-4ae9e72c-a8af-4952-ae3f-da390b0123456)

Does anybody else encounter this problem or have a fix? Is there an alternative to getting the UID of newly created environments?

I have the same problem with a newly generated API key.
Did you find any solution?

Best Regards,

Adam

This problem should have been fixed by Wednesday, 12th January 2022, but it is still not resolved as of now.
See:

@jfbriere I agree. I’m still seeing the issue on my side. I’ve asked for another OFFICIAL time for when it would be resolved, but no reply as of yet.

Hey everyone!

I looked into this issue for you and was able to find a high-priority ticket that was last updated 10 hours ago.

I’ll continue to monitor and let you know when we have a fix. In the meantime, I appreciate your patience and understanding :smile:

Hey @kevin-postman . Thank you for the reply. If you don’t mind me asking, what is the normal turnaround time for issues like this to be resolved?

Hey! Sorry about this delayed response, I was on holiday in the US yesterday :sweat_smile:

I am rather new still so it’s a little difficult to say what the normal turnaround time is for issues like these. Covid has made some things challenging with so many getting sick recently plus the holidays which is why this issue has been dragging on longer than we’d like.

Currently, a status update as of 5 hours ago is suggesting an estimated fix by January 19th.

Let me know if there is anything else I can do to help! :smile:

@kevin-postman Aw man that sucks to hear. Hope everyone is recovering well though!

@jfbriere @ThomasM Looks like the issue has been resolved. The Environments API is working on my end. Can you confirm the same for you?

2 Likes

Hi, I can confirm this has been fixed.

2 Likes

@xbynum I confirm that the issue is fixed for me. Thank you for the updates.

1 Like

Sweet. Happy coding folks!