Performance runner hangs on "Preparing to run"

Trying to run performance tests on the collection runner results in it hanging for indefinite time, even with very small users or run times.

I’ve tried closing and re-trying a run but nothing works. Manually sending out requests (or a collection-wide run) does work. It’s the performance feature that is hanging.

Nothing comes up on google, nor on the forum search.

Hi @GeraltOfDivia. Welcome to the Postman Community! :postman:

Can you please download your application logs, and send it to us at help@postman.com so we could take a close look into your account?

Unfortunately, I can’t download application logs. View >Developer > Find in file explorer doesn’t open up anything for me. I did however send an email to the address youve mentioned with a screen capture.

1 Like

Hello,

Has a solution been found for this error?. I have a similar problem.

  • Postman Web, Desktop Agent, Windows 10, Google Chrome
  1. When try to start a collection of tests, they are not started. I only see “Preparing to tests”.
  2. The problem occurred after updating Postman Agent to version 0.4.26
  3. The problem only occurs when trying to use Desktop Agent. When I switch to Cloud Agent, the test collection works without any problems.
  4. In attached is the error from console when I run test collections

Hi @navigation-cosmonaut. Could you also reach out to support so we can take a look into your account to see of there could be anything going on there?

1 Like

Ok, I sent email to support

1 Like