My authorization token is correct but the get request is not working

hello everyone
I am trying to make a GET request that will retrieve data from an endpoint, I checked and the url parameters are correct and I made authorization via auth-token but I still don’t get any result from the api

any idea why authorization is not working?

Hello, try with this link may it helps you as tutorial and :slight_smile: @mai.sa2sa2

1 Like

Hi @mai.sa2sa2!

Welcome to the community! :clap:

It seems like you are not copying the whole bearer token, it should be larger than just that, as I dont see the trailing … in your screenshot.

Try getting the whole token and try again. Let us know if that works!


Can I just add that Postman caches auth data, which sometimes causes requests to return an unauthorised response. Please ALWAYS check your request in the command line as well, by copying the CURL content. You may need to escape quotes inside quotes and replace single quotes with double quotes on Windows etc.
This happened to me this morning.
I had to regenerate my Twitter API tokens.
I knew that my credentials were 100% correct, but requests started to fail in Postman.
I tried the same request in the command line and it worked.
It may have something to do with the GUEST_ID cookie? I did remove this from the CURL and the request worked in the command line, but still not Postman.
So, there must be something else, at fault.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.