Requests fail after regenerating my Twitter API tokens?

Hi Everyone

I have a feeling that Postman caches auth data, which sometimes causes requests to return an unauthorised response.
When I check exactly the same request in the command line, by copying the CURL content, everything works perfectly.
After regenerating my Twitter API tokens, requests started to fail in Postman.
I knew that my credentials were 100% correct. I triple checked them.
I tried the same request in the command line and it worked.
It may have something to do with the GUEST_ID cookie? I did remove this from the CURL and the request worked in the command line, but still not Postman.
So, there must be something else, at fault. Has anyone else experienced this? If so, do you have a solution to refresh Postman and clear the cache.


I have just found out what is going on.

There is no caching issue.

It seems that there are two types of global variables. A set of app based variables and then there are collection based variables. It seems that the collection based variables override the app based variables. I had no idea I had set a bunch of collection based variables that were taking precedence over the app based ones.

Once, I removed the collection based variables, everything worked fine. :slightly_smiling_face:

1 Like

Hey @Charlesr1971

Glad you were able to figure that out in the end. :trophy:

There are a few more variable scopes within Postman, as well as the 2 you mentioned. More information about how these behave can be found here:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.