I can't authenticate my X account

Good afternoon all.

I am a rookie in terms of development and API so please bear with me.

I just ordered the basic ($100) version of the X API and installed the X collection in Postman. After filling in my credentials to my environment, I still get the 403 permission errors. after asking it to to the simplest fetching job

All the tutorials I’ve watched, read seem to be somewhat outdated

Hey @descent-module-astr7 :wave:

Welcome to the Postman community! :postman:

Are you following any of thier documentation to know how to get the necessary Auth details?

How do you have this set up in Postman?

Could you provide some visual examples (mask all sensitive data), please?

Thanks for having me Danny. Awesome to see such quick response from you!

I kind of merged 3 images into one. I hope you can make something from it

It looks like the token/secrets you’ve added are fine but it’s telling you, frim the response message, that something needs to be set up on Twitter side.

Maybe something to do with this?

I don’t exactly how those endpoints work and what needs to be set up first. The fact you’re getting a response like that from the Twitter server to a good sign though as it’s not a 401 code.

Thanks again, Danny.

I don’t know what going on. I tested my bearer in python and this is the response I got.

Bearer Token is not valid. Status Code: 403
{"errors":[{"message":"You currently have access to a subset of Twitter API v2 endpoints and limited v1.1 endpoints (e.g. media post, oauth) only. If you need access to this endpoint, you may need a different access level. You can learn more here: https://developer.twitter.com/en/portal/product","code":453}]}

It does not make a lot of sense because I upgraded my account. I will have a visit to the X community I suppose.

Hope to meet you again

Like I said, I’m not too familiar with that API. :sweat:

Did you create the token before you upgraded the account? Have you tried recreating a new token with your upgraded account?

Is the link mentioned in the message giving you any more details?


Are you able to access the endpoints mentioned in the response message?