Importing collection breaks forks

Your question may already have an answer on the community forum. Please search for related topics, and then read through the guidelines before creating a new topic.

Here’s an outline with best practices for making your inquiry.

My question:
When I import a updated collection my forks breaks.
How do I fix the connection ?

Details (like screenshots):

How I found the problem:
I created a collection, forked it to the same workspace, exported the source collection.
Edited the file ( mass edit API version ), imported it with the same name.
Now my fork link is broken and I can’t update them from the imported source.

I’ve already tried:
Created a fresh new collection and tested it 2 times with the same result.

Hi Daniel! Welcome to the Postman community! :smile:

When importing a collection that has a naming conflict, you should see a popup that asks if you’d like to import as a copy or replace.

When you replace, that means the old collection is deleted and replaced with this new one which is why the fork link would be broken.

Hello, thanks for the reply.
So if I get a updated API from my vendor I need to redo all forks I have for testing ?

KR
Daniel

So I would say the recommended workflow for this would be to update the API definition in Postman and then update the associated collections which means you won’t lose existing fork links.
Check out this article for more details.

Hope this helps! :smile:

Ops I see that I used the wrong name, I meant that I get a collection JSON file sent to me to import.

I believe the process would still be the same in this case.
You would have to update your collection and then pull changes from your forks.

Only way I can see if I manually compare and update the collection. If I import the file it breaks as you confirmed.