I run a POST request in POSTMAN with 3 query Params and get a 404 error. How do you fix not found error?

Your question may already have an answer on the community forum. Please search for related topics, and then read through the guidelines before creating a new topic.

Here’s an outline with best practices for making your inquiry.

My question:
I am trying to run a simple Maven Project using eclipse as an IDE. I want to run a POST requirest using localhost:8080/persons. Everytime I restart the apache server and send a POST request in POSTMAN, the error message comes back saying not found and 404. I am trying to send 3 queryParameters.

Details (like screenshots):

How I found the problem:
I found the problem rerunning the Maven application multiple times and trying a POST request to test it out. I keep getting the same error message in the body.

I’ve already tried:
I tried localhost:8080/person in my chrome web browser, it gives me WhiteLabel error 404. Is there any articles or things to try for a solution so I do not get this error?

Hi @kirkish.2

Not sure this will fix the problem but the orange dot in the tab at the top means you haven’t saved your changes;


If you look on the left menu list it is still showing as a GET request.

Save it and try again, then let us know if you still have the issue.