Error: read ECONNRESET while executing through Newman and collection runner

Hi Team,

I am new to POSTMAN and i have been facing error “Error: read ECONNRESET” while running the collection through Collection runner and New man

This issue is existing for request that are having response more than 4 seconds, and that too not every time. While running the request in manual way by clicking Send it is giving valid response

The request which shows error “Error: read ECONNRESET”, may not show the error again. It is intermittent issue… But its pointing towards stability issue in collection runner and newman

It would be a really good if someone could help with the above issue

Hey @sonutitus

Is there a reason that you have the 2 setTimeout functions in the script?

Does the connection timeout after a certain amount of time?

What’s the response time of the request that passes compared to the same request the is intermittently failing?

Hi @dannydainton ,

Thank you for the quick response.

The reason I tried using timeout is because this ECONNRESET issue, so the timeout would actually wait for the response

1st Timeout is used to wait 2 seconds after getting the response and the second time out 1 second is used to wait before storing the response to variable.

But timeout itself was just workaround i tried to achieve to solve the ECONNRESET issue, but was not successful

The response time passes : anything below 3 seconds are working

@dannydainton

No, there is no connection timeout while Sending request using the script using SEND button

@joyce
Hi Joyce,

Hope you are doing good.

Could you please suggest some work around if you have faced the above issue. ? There are almost 132 request in total