Error "read ECONNRESET" displayed while running Postman collection using Collection runner

I am running a simple Collection with API requests having Environment variables in endpoints and request body as well. Also, I have some test scripts written for some of the requests.
If I select and run some requests from the Collection in the Collection runner, it runs successfully. But when I try to run the Collection as a whole, it fails with the error “there was an error running your collection: read ECONNRESET”

Can anyone please tell me what can be the cause of this? Please let me know any other information required to address this issue.

Hi @abhinoy,

Welcome to the community! :clap:

You have quite the interesting issue there. Can you do the following check for me?

  1. Run each request in the collection individually, see if you can isolate one request thats having the issue.

Can you provide a bigger screenshot of the issue? This might be difficult to troubleshoot but we’ll try. Its possible that your endpoint is reseting the connection for some reason, maybe due to quick succession of requests. We might have to add a delay but for now, lets isolate the issue to see if its exactly only when the collection is run as a whole, or if there are specific requests that trigger it.

Best,
Orest

Hi @odanylewycz thanks for the warm welcome :slight_smile:

I tried running all the requests individually and was not able to reproduce the error. But more than one request… and the issue reappears.
Now, I wasn’t able to pinpoint the reproduction of the issue by the size and/or the number of requests. But it appears that including multiple POST requests always produces the error(s). (I have tried with more than 10 GET requests and they all got executed without any errors)

Also, new error message while running a bunch of requests (18 POST requests to be precise, I don’t know if the METHOD VERB matters or not):
“There was an error running your collection: socket hang up” (this error message is intermittent)
When I click on the blue ‘Retry’ button, the runner throws the “ECONNRESET” error again.
image

These 2 requests together also throw the error:
image

You’re welcome :slight_smile:

Hm, the issue seems sporadic and quite specific.

This issue gets pretty low level and can get complicated so I may not be able to fully help. Basically, my understanding of the issues lies on the networking side. I do now know how much access you have to the endpoint that you are running the requests against, buts its possible you are being blocked by the web service you are testing against, and receive a socket hangup because the TCP connection is being dropped or blocked. Its hard to say when only having this information.

My best recommendation from here would be doing a wireshark trace of the network activity. That should provide more information as to whats happening. But without those packet captures, I can’t say much else on whats going on.