Could not send request Error: Request timed out

Here’s an outline with best practices for making your inquiry.

My question:
trying to run get request but having issue
but having this error
Could not send request Error: Request timed out

Details (like screenshots):

curl request

curl --location --request GET ‘https://testapis.tawal.com.sa:9502/mobile_app_employee-camunda/api/empl/camunda/v1.0/mobile/my-group-tasks/9c4378db-b3fc-4de8-9bf6-8ea77f5fb1dc?start=0&pageSize=10&status=PENDING’ \

–header ‘on-behalf-token: eyJ0eXAiOiJKV1QiLCJub25jZSI6InJSUWJGbV9FaUJVNWx6WnZpbW5wbVVJd0hpUHpETGFkU3Blb3FhNnVPazQiLCJhbGciOiJSUzI1NiIsIng1dCI6ImpTMVhvMU9XRGpfNTJ2YndHTmd2UU8yVnpNYyIsImtpZCI6ImpTMVhvMU9XRGpfNTJ2YndHTmd2UU8yVnpNYyJ9.eyJhdWQiOiIwMDAwMDAwMy0wMDAwLTAwMDAtYzAwMC0wMDAwMDAwMDAwMDAiLCJpc3MiOiJodHRwczovL3N0cy53aW5kb3dzLm5ldC9mNDA5YTEzYy1iYzU2LTQ3NzktOGZkYi05NDg3NzNmMDU1NjQvIiwiaWF0IjoxNjQ3NzY2MDUzLCJuYmYiOjE2NDc3NjYwNTMsImV4cCI6MTY0Nzc3MDUwNSwiYWNjdCI6MCwiYWNyIjoiMSIsImFpbyI6IkUyWmdZTkNzdEZ6d3JVa3pzSXVWVzBvMi9NMm4zb2NhZDZVOVgrejY1bUZ4cXZqT3laVUEiLCJhbXIiOlsicHdkIl0sImFwcF9kaXNwbGF5bmFtZSI6ImVtcGxveWVlLXdlYiIsImFwcGlkIjoiNzhjMThhNTQtOGJlMS00ODA5LWI5ZDAtYTNhNjNjMmVlMTYyIiwiYXBwaWRhY3IiOiIwIiwiZ2l2ZW5fbmFtZSI6InNvZXBvcnRhbF90ZXN0aW5nXzEiLCJpZHR5cCI6InVzZXIiLCJpcGFkZHIiOiIxOTcuNjAuNjYuMTI5IiwibmFtZSI6InNvZXBvcnRhbF90ZXN0aW5nXzEiLCJvaWQiOiIzZjkwODQxOC01YzM5LTQ0YTAtODc0OC01YWM5NTNkYjM4NjMiLCJvbnByZW1fc2lkIjoiUy0xLTUtMjEtMTc1MTcyMDMyOC0xMDA2NDIwNzQ1LTI2Mjg1NTkzMDItNTgzNCIsInBsYXRmIjoiMyIsInB1aWQiOiIxMDAzMjAwMTkwMTUxNkM5IiwicmgiOiIwLkFUc0FQS0VKOUZhOGVVZVAyNVNIY19CVlpBTUFBQUFBQUFBQXdBQUFBQUFBQUFBN0FGRS4iLCJzY3AiOiJBcHByb3ZhbC5SZWFkLkFsbCBDaGFubmVsTWVzc2FnZS5SZWFkLkFsbCBDaGF0LkNyZWF0ZSBDaGF0LlJlYWQgQ2hhdC5SZWFkQmFzaWMgQ2hhdC5SZWFkV3JpdGUgQ2hhdE1lbWJlci5SZWFkV3JpdGUgRGlyZWN0b3J5LkFjY2Vzc0FzVXNlci5BbGwgRGlyZWN0b3J5LlJlYWRXcml0ZS5BbGwgZW1haWwgRmlsZXMuUmVhZC5BbGwgRmlsZXMuUmVhZFdyaXRlLkFsbCBHcm91cC5SZWFkLkFsbCBHcm91cC5SZWFkV3JpdGUuQWxsIFByZXNlbmNlLlJlYWQuQWxsIFNpdGVzLlJlYWQuQWxsIFNpdGVzLlJlYWRXcml0ZS5BbGwgVXNlci5SZWFkIFVzZXIuUmVhZFdyaXRlLkFsbCBwcm9maWxlIG9wZW5pZCIsInN1YiI6IkhzNzNSMm9DczFHT2JwU0Vlenp0NjNoZnljaDRHQmZIZk1EVlRzN2ZJaGciLCJ0ZW5hbnRfcmVnaW9uX3Njb3BlIjoiRVUiLCJ0aWQiOiJmNDA5YTEzYy1iYzU2LTQ3NzktOGZkYi05NDg3NzNmMDU1NjQiLCJ1bmlxdWVfbmFtZSI6InNvZXBvcnRhbF90ZXN0aW5nXzFAdGF3YWwuY29tLnNhIiwidXBuIjoic29lcG9ydGFsX3Rlc3RpbmdfMUB0YXdhbC5jb20uc2EiLCJ1dGkiOiJkeWNocklEdXEwdWE0bnpQQWtwREFBIiwidmVyIjoiMS4wIiwid2lkcyI6WyJiNzlmYmY0ZC0zZWY5LTQ2ODktODE0My03NmIxOTRlODU1MDkiXSwieG1zX3N0Ijp7InN1YiI6InJXbVZhREk2Vld1ZF82TFlvcEp6d1NPZlF1UWlTRk0zWmp4YzZndkxtTXcifSwieG1zX3RjZHQiOjE1NTQ4ODQzNTZ9.D3JdRYV4NrJmhvCcy4iOLi-2ZYE6gnbnYck_IvOUEg4cx05yD_8KGUwQqKr2gJ75ZPrB7i1zEjk7-K0gaJqr2aNpeuLp82uhIPLx0vjDoDEhJV6E766Z_UfbiwQpccxcpDzzkbwhdNhpOB_xa7MPlB5sVYQKqPU5VGmY5sjtzR1g6wgQ1j7bzzm0omga4hCA7swDhKJbmZJCZ34YCCsH2NerZq20cLwBc9LgXgFd96wFsQbSkm6Wfhf37datmPt85xIvmEShAaga9k90qelXGhcbOhFqPbUETiH4gC-hrGirFxCfAh_IZ2Jtss6ogwv7cQenhLnQv1B-QzNiechOkg’ \

–header ‘Authorization: Bearer eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiIsImtpZCI6ImpTMVhvMU9XRGpfNTJ2YndHTmd2UU8yVnpNYyJ9.eyJhdWQiOiI3OGMxOGE1NC04YmUxLTQ4MDktYjlkMC1hM2E2M2MyZWUxNjIiLCJpc3MiOiJodHRwczovL2xvZ2luLm1pY3Jvc29mdG9ubGluZS5jb20vZjQwOWExM2MtYmM1Ni00Nzc5LThmZGItOTQ4NzczZjA1NTY0L3YyLjAiLCJpYXQiOjE2NDc3NjYwNTMsIm5iZiI6MTY0Nzc2NjA1MywiZXhwIjoxNjQ3NzY5OTUzLCJhaW8iOiJBVFFBeS84VEFBQUF0RUg0VktVY2NQNEE4VHMwajkwVDk2QXFZSi85ZnRKdHhhMmlIWE1zV0xCcUdKSWFHQWl3VDg3akdQbTlJR2I0IiwibmFtZSI6InNvZXBvcnRhbF90ZXN0aW5nXzEiLCJub25jZSI6IjBiZmU1M2Q1LTgyZDktNGMwOS1iMDVkLTA1ZWYxN2U3NTJlMiIsIm9pZCI6IjNmOTA4NDE4LTVjMzktNDRhMC04NzQ4LTVhYzk1M2RiMzg2MyIsInByZWZlcnJlZF91c2VybmFtZSI6InNvZXBvcnRhbF90ZXN0aW5nXzFAdGF3YWwuY29tLnNhIiwicmgiOiIwLkFUc0FQS0VKOUZhOGVVZVAyNVNIY19CVlpGU0t3WGpoaXdsSXVkQ2pwand1NFdJN0FGRS4iLCJyb2xlcyI6WyJhNTUyMzQwOS1iNzMyLTQxMWYtODEzYS1jZTAyNGU0Mzk4NDUiLCI4NTJkN2FmYS0yMWM0LTQyMWItODlmNS1lODZhOGIyMDY2MmQiXSwic3ViIjoicldtVmFESTZWV3VkXzZMWW9wSnp3U09mUXVRaVNGTTNaanhjNmd2TG1NdyIsInRpZCI6ImY0MDlhMTNjLWJjNTYtNDc3OS04ZmRiLTk0ODc3M2YwNTU2NCIsInV0aSI6ImR5Y2hySUR1cTB1YTRuelBBa3BEQUEiLCJ2ZXIiOiIyLjAifQ.qdTrSr5LcKdOrNJVYZP3RCqZKfR8UhCn36Redtve9oKD-iRPgP_up32jrUqnLa22i3oqD63b4mYQwuX8KLOqZj4yOgZD0Jpd9CM1Pzyj-_FaS8G9b_VIoukqAsu1r5aEw_ES0o2ecH75dXJEGw-2OIZYi7BgNfLC5spTIRtsNL3B6e7kydbAYdAVsr3UmQsHqHYyrxkdKODCCx40QINrcNE_2sBldXHXD2lTqdeiDkFAUz8fY2OR7ZjNLVfGwFWzkwNX_uXtXBb0-_hFCmVrF2JCpErrHwbDOMYJ-YD_JJLbIZQrLC0j8oIGE7B7xYeyk8lDJD4aUQ-4H-vKFitL7g’

Hi @just_91

Are you sure that the API end-point you are trying to hit, exists?

1 Like

@w4dd325 I am having exactly the same issue, but I have sent my request to other team members and they are having no issues making it. So in my case at least, its not a matter of whether the endpoint exists, but that something funky is going on with my Postman.

I have reinstalled and gotten the latest version, but no dice.
image

Can you send the curl command manually from the same machine?
From the command line or from something like reqbin.com

You can grab the curl command from Postman here;

No I cannot send a curl command, it fails to send. I did some further investigation and found that I could send the request directly to the backend URL that we are using, but was unable to send it to the frontend. Perhaps this is a firewall issue or something similar? Regardless, it doesn’t seem to be an issue directly with Postman.

I appreciate your responses :slight_smile:

1 Like

Firewalls was going to be my next question. :+1:

1 Like

I am having this issue also. i can send the request through a browser and from command line. It only fails with postman. Any ideas?

If it onyl fails in Postman I would suggest re-checking your request and headers.
What is the response code you get?

Error: connect ETIMEDOUT 10.0.75.1:80

:arrow_forward:Request Headers

Accept: application/json, text/plain, /
Accept-Language: en-US,en;q=0.9
Connection: keep-alive
Cookie: remember_web_59ba36addc2b2f9401580f014c7f58ea4e30989d=eyJpdiI6IjAxYkExVG95WHFUUTU2M2NvTFZONlE9PSIsInZhbHVlIjoib3gxdUxDM1Q3aXBKQzJSZ0JoZ3RkeExBdnROZzhEdzEwbFVZM0IzYnNITFA3QU5lSmRvV21FL1dKZTAxUEhGR281Q1dRVUZzM3gzc2pKaWZMUHJIcHUzaTlPYVBsREJZM3pRK3Q1cTJaeURnQXBvSlg4KzhLZ1pUOEZEV0VQM0FkcmgzVVpPcEYrdWNubThuZGdNZ1BiWUxVcVdEbngxVW1mOG43VkdGKzBKY09NVGRBQW42YjBoazdJbkdDMnltb0lLV0FWY0tFSG94UzhRUmdWRzNET3pST1JMNnpleFA3Yld6MUFqN3BiOD0iLCJtYWMiOiJiN2YzYzMzNGE0ZTI5MDJhYWE3M2Y3MmFiYTNkZjFlMDlmNWU0MTAxMThiMDExYWU2ZGVkNTlmZjI4MGU1ZTM5IiwidGFnIjoiIn0%3D; laravel_token=eyJpdiI6InhJaW5CWHJ2ZkZPaVhIcCt3MTIrK3c9PSIsInZhbHVlIjoiZEZqc2VQamtyRDdPY2crK0hGVVZjTG9kMm1iV0M4ZnBUTUxVTmxTemtpSXNoeXcwSm5WQ3F0RWl2N29CM2J2MXluYm1TMUovRFlzYjczK2t4S0F2NEFySElydy9iZEhwN0hFUlNTcFZTdE40RkxmNTlPUmVtREVRVVVtZVpZeVNGdGx4K2svTVRoL2hoWHp6aXdLeDJCenVLWXovSUlwQ1BOWk41MGxSOXFUZ3liZnIzZVpaNkdwRHlUSnRaQmV5dkhuQ3pTU2w5MFJpaS81VTUram1MZ3NyNFh3Q2NlKzMzVW9VWUJuUmVqU3JuWW0wS3Njd0NDa2t5bkRWdXFOcmVBbU1sQmRVdzNLN3pXVVdhNklVMFVmV25UdUtFRUNPeUFqck1JQU10OWpiRE1NU0RXa3ptNk5uaDFRYkVjd04iLCJtYWMiOiI2MDliZWMwZTZkNjg2MTg2ZjA4YTFjNzkxMDJmYTJkOTZiYzY1MDBhOTQ0ODY4OWY1NmQ1NDVlZTFkNDc3ODUwIiwidGFnIjoiIn0%3D; XSRF-TOKEN=eyJpdiI6ImhZdFlrTVRDY2hCQlVqT2lxeGlUM2c9PSIsInZhbHVlIjoia3FtMXQzempqbVlPeWlZRkUxYVNreUF4NVZpRGJVelFUald3MVozZkVNalAwdDBZNU5Ea0JZelIrYXQwYnpVdmxqUU9VYzhZM3lpa2lTa1IyRWpmdHlMZkNiMTZLWENCa0JPc3lONm9xMkx0WkVLMXB5YlQ3UnlzVVJqQWtuZm4iLCJtYWMiOiI2ZTVjNDdjOWZkMjY0YzEyNTcxOWM5MDhmODhhMjFiOWNiY2M1NDZlMTRmNTJmNTMxN2ExMTM0ZWM2Yzc3NjA4IiwidGFnIjoiIn0%3D; facebook_clone_session=eyJpdiI6IlErRUYycm5DZE01L3BBQ0s3QlREM0E9PSIsInZhbHVlIjoiS2dMSEUxOFE5Z2FnSVZGMlJ6VWFWdkpqVFFuRjdkdTRocDVleEwwc21VYzQ3ZDNUc1BMSGhNRy9wb2tJOVl0YSsrN2g2UGNHbkRscFo1RTU3M3k2MURSRkorVzZocStTd2lvZEh1TTI0R2c2YmJxVGtTejByV2xFZ1l3NXY1WFUiLCJtYWMiOiI5ZjdiM2Y4N2Q5MjZjNzJjOGQ1OTBlOTVmMDMwNDY5Y2UzYTUzZTViM2VlMzZmZGNiN2E4ZDgzZDk0MWE2OTMwIiwidGFnIjoiIn0%3D
Referer: http://facebook-ct.local/
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.127 Safari/537.36
X-Requested-With: XMLHttpRequest
X-XSRF-TOKEN: eyJpdiI6ImhZdFlrTVRDY2hCQlVqT2lxeGlUM2c9PSIsInZhbHVlIjoia3FtMXQzempqbVlPeWlZRkUxYVNreUF4NVZpRGJVelFUald3MVozZkVNalAwdDBZNU5Ea0JZelIrYXQwYnpVdmxqUU9VYzhZM3lpa2lTa1IyRWpmdHlMZkNiMTZLWENCa0JPc3lONm9xMkx0WkVLMXB5YlQ3UnlzVVJqQWtuZm4iLCJtYWMiOiI2ZTVjNDdjOWZkMjY0YzEyNTcxOWM5MDhmODhhMjFiOWNiY2M1NDZlMTRmNTJmNTMxN2ExMTM0ZWM2Yzc3NjA4IiwidGFnIjoiIn0=
Host: facebook-ct.local
Accept-Encoding: gzip, deflate, br

I can pull the curl directly from the postman code tab and it runs. It doesn’t make sense.

According to this documentation, it sounds like a network issue.

https://nodejs.org/api/errors.html

ETIMEDOUT (Operation timed out): A connect or send request failed because the connected party did not properly respond after a period of time. Usually encountered by http or net . Often a sign that a socket.end() was not properly called.

Check your Postman settings. See if it’s running through a proxy or something like that;

Yep. I turned off all proxies. I even thought that it was my windows firewall but I turned it off and still didn’t work.

Running out of ideas if im honest …

what is facebook-ct.local? is that a locally hosted site?
The timeout appears to be on IP address 10.0.75.1:80, so im guessing it is something you are hosting?

It is a laradock site.

My only other idea is that there is a problem with the way postman interacts with docker sites but I am not finding any solutions online.

Maybe the info on here will help?