Could not get any response, socket hangup error

I have seen other posts regarding “Could not get any response” but none with socket hangup errors. I am using Postman 7.11.0, I created a PUT request that sends a request to a BOOMI API. This request creates a sales order in NetSuite. When the request completes Postman displays “Could not get any response”. When I look at the Boomi process I see that it ran, successfully created an order in NetSuite and sent the response back to the requestor.

When I open up the PM console I see “Error: socket hang up”. I have turned off SSL certificate verification. Global proxy config is turned off as well as Use System proxy. Request timeout is set to 0, I even tried setting it to 5 minutes instead of infinity.

I am not sure what else to try. Please, any help/ideas is greatly appreciated.
Thanks in advnce.

Hi @jled,

Welcome to the community! :clap:

In regards to your issue, this might be difficult to troubleshoot with just Postman tools, but we can give it a shot.

Can you show us a screenshot of the error? Is there more detail to it?

If not we can try to see if the developer tools will help us (clicking F12 should pull them up in Postman), by sending the request again, and looking at the response in the console, and in the “Network” tab of the developer tools. You may be able to see what came back more clearly.

If that doesnt help, you may have to take a pcap using Wireshark to see the traffic going back and forth. This may provide more clarity into what response Postman received that made it throw the error. From what it seems, it sounds like it sent a premature TCP FIN packet (meaning finished), but I cant be too certain on that. Using Wireshark can be addressed if it gets to that.

Let us know!


Hi Orest,
Thanks for the response. I will include a screenshot of the error (with some info blanked out). This is the error in the console. I tried opening the dev tool but it is the first time using and it did not show any network traffic or any other info when I sent the request in Postman app on MAC. I will try again to figure out how to get that working.