"Could not get any response" AT STARTUP TIME

I googled the phrase, and I appreciate there seem to be loads of people suffering the same problem, but a lot (most?) of them seem to be getting the problem when they send a request.
My problem (okay, slight irritation) is that I get it when I start Postman in the morning. I have about 45-50 requests in various collections and I think I’m seeing a “Could not get any response” for each of the 45-50 requests.
Once the messages all disappear, Postman works fine; I can send in a request and receive the answer. If I close Postman and restart it, same messages. I had the console open when I closed Pm, and it was automatically opened when I restarted Pm, but nothing was written there.
Any suggestions ?

Hey @misi01

Could you provide some images or a recording of this happening, please.

It’s much easier to show UI based issues than to describe them :grin:

Thanks for the quick reply. The best I could do was to take a photo of it. Hope this helps.

I could also take a recording if that would be better

Does this also happen if you close all the tabs before closing/restarting the app?

When you say “close all the tabs”, I’m sorry, but could you expand on that please.

All the request tabs that you have open in that image. Close them and try the same scenario.

If the attached screen capture was what you meant, that didn’t help. In addition, even though they were all closed, when I reopened Postman, the JPB261 collection had been “opened/expanded” automatically

It’s really difficult to know what you’re doing for the cropped screenshots, to be honest.

I meant to close all the request tabs (GET C... , GET K...) that can be seen in your images:


Using this option is the easier way to do that:


Once you have done that, quit the app (via the File option). When restarting the app, are you seeing those same toast notifications appearing in the UI?

This is not a solution to your problem, I just wanted to see if this was related to certain request tabs that you have open in the builder.

That seems to have solved the “problem” for me. Thanks a lot.

Do you happen to know if any of the request tabs you had open were part of a delete Collection?

No, they weren’t. All the collections I have are ones that I’ve created once and then added requests, one at a time. I might have deleted a request, but that’s about it.

I’ve noticed that if the have a tab open and delete the request from the sidebar, closing and opening the app shows the same error toast.

Would you be able to give that a go and I will speak to the team about the behaviour.

Will do (2morrow) if I can do EXACTLY what you meant :grinning:

Not sure if this is what you meant, but here we go.


However, I did see this after restarting Postman (note that I hadn’t closed all the request tabs as you suggested earlier, so I saw a couple of “Could not get any response” messages again).

We raised an issue for this yesterday and discovered that the work was already being done by the team responsible for that area of the product.

This should be fixed in the next app release.

Great. Again, thanks for your speedy replies and help.