Could not complete OAuth 2.0 login. Check Postman Console for more details

Please search for related topics, and then read through the guidelines before creating a new issue.

Describe the bug
I tried to connect with my customer to upload the image to their website through API. before doing this, i have to establish the connection with them using Oauth2; grant type : password credential ; then i got the error message below while trying to request the token “Could not complete OAuth 2.0 login. Check Postman Console for more details”

Steps to reproduce the behavior:

  1. Go to :Authentication

  2. Click on : request new token
    3.Grant type : password credential

  3. See error
    “Could not complete OAuth 2.0 login. Check Postman Console for more details”
    Screenshots
    If applicable, add screenshots to help explain your problem. Please make sure images or code samples don’t contain authentication tokens or credentials.


    App information(please complete the following information):

  • App Type: CHROME
  • Postman Version :V7.2.2
  • OS: window 7

And did you “check Postman Console for more details”?

Also, I’d recommend using the Postman native app as the Chrome app has been deprecated.

1 Like

I too have the same issues, but for me the reason for this is, after receiving the code the token request method need client secret again which postman does not add to.

I fixed this in my system by disabling “SSL certification verification”. Access this setting from File > Settings > General Tab > REQUEST Section > SSL certificate verification = OFF:

I am also getting same error "Could not complete “Oauth 2.0”

i am getting request time when i try to ping getpostman.com in command line ,Is there any change do i need to do in network setting

please help me

I have same problem, can’t get token. Body/Auth header choice is wrong. Both must be sent to the KeyCloak otherwise it reject a request. I confirm this by sending POST request to KeyCloak directly.
Fields client_id and client_secret must not present with grant_type=password, this also causes rejection by KeyCloak. PostMan puts these fields into body even if they are empty.

Also have the same issue on one of my two consoles on the same collection. I have the console on my mac and a PC. I only get the error on my PC. I have looked at the SSL, which is on on my mac and working I’ve tried both on and off on my PC that isn’t working. Saved on my Mac and opened on my PC and still not working on my PC.