Cannot reimport a large Postman collection

I am not able to import a 290 MB PostMan collection.

At first, I was not able to create a pull request for a large collection I had. So, I deleted the original and kept the forked collection that I had already been working from. Then, I thought this may be causing the problem to have a forked collection with no original. So, I deleted the forked collection also, leaving me with no collection locally with this name. Also, I have the file saved off to the side, so I can import it back at any time. But, upon trying the import of the file I had saved off to the side on my Mac, the import is failing. So, I am not sure if the extra steps mentioned here are causing an issue.

So, I then copied the collection file and renamed it. Then, I tried to import this renamed collection file also, to avoid using the same name as the original collection, in case that was the problem. This did not help either. So, right now, I have no collection for this in my PostMan app locally right now. I still have the file saved locally on my Mac though, so I can fix this at any time. Any advice on how I can import this into my Postman app now?

Hey @twhitehouse-ecolane :wave:

Depending on when this was deleted from the Workspace, have you tried to recover this Collection from Trash?

No, but I don’t need it. I did not explain this so great after rereading it, sorry about that. The forked collection had my new changes. So, that is what I really wanted. But, I couldn’t even create the pull request because it was too large. So, that is when I started deleting things.

But, like I said, I have the forked collection locally and can import it again and start over. But, I cannot import it. If I can import this collection I have on my Mac, all will be good.

Hey @twhitehouse-ecolane

I’ve checked with a few teams around Collection import limits and we don’t restrict that by size, depending on the time the import takes, there could be other factors at play here.

Was there a specific error message that you saw when importing the Collection into a Workspace?

Is this a Workspace that you have Admin access on or do you hold a different role for the Workspace?


Thanks for asking. Now that you mention it, I tried again and watched for all the details. Yes, another modal is shown that tells me I am offline like this:

“Looks like you are offline
Until you’re back online, data in your workspace may not be up to date.”

So, I tried to import a much smaller collection, and this smaller collection imported in a few seconds with no issues. I only see the offline message when I try to import this large collection.

I won’t write off connection issues on my end. They can always happen. However, I doubht that I have connection issues every 30 seconds. Also, everything else appears to be online. I have JMeter tests running at the same time, I am posting here with no issue, my Slack messaging is open and not reporting offline, along with a few other things that all show no signs of being offline. I would lean towards having a good network connection the whole time.

Thanks for giving it another go. :pray:

Are you using the desktop app or the web version for the import?

I am using the desktop app on Mac.

I will also mention that I just now tried to do the same thing on the web app and I received the same message.

To help gather more information, I just zipped this collection up and gave it to a colleague. I asked my colleague to try and import this collection also and let me know what happens. I will have more information shortly for how that goes.

I appreciate you trying different methods and asking your colleagues to try too :pray:

If you wanted to connect via DM and share this with me to try on my end, I can do that for you and try and see if I can see something happening. I appreciate that the contents may not be able to be shared though.

Also, I missed one of your other posts about restoring the collection. I just tried this and I was able to restore the collection. So, that collection is ok.

However, this is only the original. My forked collection is on my desktop still. This has my new updated tests and is the one I want. I still cannot import this either as a copy or replace. I am still getting the same error about being offline.

You’re right, I cannot do that for various security reasons. It was a good idea though. I’ll still update once my colleague tries.

My colleague tried also. He was not able to import using the Desktop app or the web app either.


I’m having a similar problem. Did someone managed to find the solution?



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.