A single test fails Student Expert

The test is failing in the test collection request in the 3.check progress folder

Can someone help me with this

This is the URL

Hi @abhiGamez! This test is on the requests in the second folder so I would recommend going back over those (there must be something missing from your test scripts in there), making sure everything is saved, then updating your collection link by going back through the Share option before trying the final request again… :slightly_smiling_face:

1 Like

@suesmith I tried to redo the entire folder, but still met with the same error :frowning:

I can’t give you the answer because part of the purpose of this is checking you’re able to carry out the steps independently so I’ll give you a hint of what I think the issue might be based on a quick glance :wink: - the test fail message mentions setting an environment variable, this means that your code should be designed to set a var in the environment specifically.

@suesmith solved it finally :sweat_smile: ,thank you for all your support ,what should i do now

@abhiGamez Great :clap: So now all the 10 Tests are passed.

  1. You can now save the collection.
  2. Go to share collection, and click “Update Link”.
  3. Get the public link and submit to: bit.ly/student-expert-submission

Note: Make sure to update the link before copying. Steps to be followed in order.

You can expect the Badge in two to three weeks considering the season holidays :slight_smile:

Have a great Day :bouquet:

1 Like

I have received my badge, Is there anything else can do now

@abhiGamez Great to know :trophy: Nothing else required from your side regarding the badge process, until you want to share your badge in social forums :wink:

Please go through this:

Happie Learning!!


@bpricilla @suesmith
I need Help!
I am not getting where I missed to save the Request!
I already tried all request once again but still facing the same “fail”

Hi @akshaycse25 - if you look at the failing test it’s indicating that you haven’t included variables in all of the places they are expected. There are a few places in the first two folders that variables are required so I would recommend going back through the steps to find which one(s) you’ve missed, then save and update your collection link before trying the test request again… :slightly_smiling_face:

Could you please Indicate me from which exercise I have to check!

Hi @akshaycse25, based on your screenshot I could see the “Used Variables” test is failing. I can give a hint to check if you have added the variables needed in any of your test. Also you can check the “Tests” section code to understand more :wink:
That’s all I can do… Please go through once again, you will be able to debug it :blush:

TypeError: Cannot read property ‘0’ of undefined
Coming this on the Runner

Im experiencing the same issue. Help me to solve this