Unable to run collection from jenkins


I am trying to run m collection through jenkins but it shows below error:

** Started by user trideep mukherjee Running as SYSTEM Building in workspace C:\Program Files (x86)\Jenkins\workspace\Newman [Newman] $ cmd /c call C:\WINDOWS\TEMP\jenkins8980552465408575800.bat C:\Program Files (x86)\Jenkins\workspace\Newman>cd C:\Users\tride\AppData\Roaming\npm\node_modules\newman C:\Users\tride\AppData\Roaming\npm\node_modules\newman>newman --version ‘newman’ is not recognized as an internal or external command, operable program or batch file. C:\Users\tride\AppData\Roaming\npm\node_modules\newman>exit 9009 Build step 'Ex**

I have tried the all possible ways mention in the blog to add the local path of the newman but didn’t worked.
Please see the environment variable I have addedjenkins

I think I had the same issue before on Mac. I solved the issue by adding a build step installing newman first via a shell command.

Thanks for the Reply!!
That means I need to write following command in build step
npm install -g newman?

I have set it up in Azure DevOps - in there, I have also set up a build step for installing newman on each run with this command:

npm install -g newman