Cannot run newman on jenkins [newman :command not found]

Hi all,

Please, I am running into an issue running Newman in Jenkins. I am able to execute my API test on Linux box itself but not on Jenkins. I am getting this error when I try to execute via shell newman: command not found. I also set my environment variables on Jenkins using PATH = /usr/local/bin:$PATH newman -v

Image attached:

I really appreciate your help



Append newman local system foder path before you set configration


C:/Users/jkalaria/AppData/Roaming/npm/newman is my local system path than enter run and than your collcetions detail

so “Local newman system path” run “Collection detail”


Hi Team,

I am also getting same error but my Jenkin is in AWS EC2(Linux) , Please help me to resolve this.

In AWS CLI, I have installed node js and newman and could able to run newman commands but when i run same command from Jenkin UI which is present in same AWS EC2, I am getting below error

[Collection_run] $ /bin/sh -xe /tmp/
+ newman -version
/tmp/ line 2: newman: command not found
Build step ‘Execute shell’ marked build as failure
Finished: FAILURE

Please solve this


In AWS CLI , i am getting response properly

worked perfectly after giving the full newman path before the collection run command

Worked for me also - Thank you

Thank you very much. It fine after add full path by your advice

Can someone give me the exact Shell command for MAC to fire it off correctly , my builds keeps failing

cd /Users/johanlindstrom/Development/Postman/
cd /Users/johanlindstrom/node_modules/newman

newman run Collection 1.postman_collection.json