REHL - Unable to login to postman

I’m running the Postman Desktop app for Linux (Fedora) on RHEL 7.4 and suddenly I am unable to login to the app unless I run it as root.
I tried logging in using Google as I have always done and it just takes me back to the application window with just the login screen.
I tried resetting my password and logging in directly. I get the same result.
Selecting any of the menu items in the application window does nothing also. File > Preferences and nothing happens.
I uninstalled the 5.5.0 update and reinstalled it again and that did not help.
However, If run postman as root: sudo postman… It works fine, the application comes up already logged into my account and synchronizes fine.

The only thing I haven’t tried was removing the ~/.config/Postman directory because I was afraid I would loose all my collections… or worse.

Any help would be greatly appreciated! I really hate to run have Postman as root…


Hey @jslaurenza, does your user have permissions to read/write files in the ~/.config/Postman directory?

Seems to me that you maybe installed Postman as root and now the root user owns your postman configuration.

You can check the owner of the config directory by running ls -l ~/.config | grep Postman.

If you don’t own the directory, you can change the owner by running sudo chown -R <your-username-here> ~/.config/Postman. This should fix the problem.