Postman interceptor is not capturing POST requests with non empty body

Your question may already have an answer on the community forum. Please search for related topics, and then read through the guidelines before creating a new topic.

Here’s an outline with best practices for making your inquiry.

My question:

Hello everyone,
I found out that postman stopped capturing post requests with non empty body. Is that expected behaviour ?

Details (like screenshots):

How I found the problem:

I’ve already tried:

I’ve tried removing body in request(used js fetch api for that) and then postman was able to capture that

Hi @Dev1801 !

This is certainly unusual behavior. The Postman Interceptor should be able to capture all requests, including POST requests with non-empty bodies.

Here are a few steps to help diagnose the issue:

  1. Update: Ensure you are running the latest versions of both the Postman app and the Postman Interceptor extension. Sometimes, issues are resolved in newer versions.
  2. Extension Permissions: Check if the Interceptor extension has all the necessary permissions in your browser. It might be restricted from accessing certain request types or content.
  3. App and Extension Sync: Ensure that Postman Interceptor and the Postman app are correctly paired. Sometimes, unpairing and re-pairing them might solve certain syncing issues.
  4. Browser Network Tools: Use the built-in developer tools of your browser to confirm that your application is indeed sending POST requests with a body. This will verify that the issue is with the Interceptor and not the source of the request.
  5. Filters: Check if there are any filters applied in the Interceptor that might be preventing the capture of specific requests.
  6. Reinstall: Consider reinstalling the Postman Interceptor extension. Sometimes, a fresh installation can clear up unexpected glitches.

There are a few other things such as unsupported browsers or conflicted extensions that could also be at play.

If, after trying the above steps, you’re still experiencing the issue, it might be worth sharing this with our official support.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.