Postman CLI usage

Short question -Does Postman CLI run locally or from the cloud?

Background - I have started using Postman for api based scripting of services to a local private network. I have previously been successfully using the collection runner to select an environment and a data file that contains multiple rows of data/variables in a csv. With the new caps in place I am now struggling with the limitations and exploring alternative methods to run my collection. Support has not been able to offer solutions and a few times has offered solutions that don’t actually exist. The scheduled runs do not work because these run from cloud and cloud can not access my local/private url. There was a suggestion of importing a file in bulk edit which doesn’t appear to exist. There is a suggestion of pm.iterationdata but it looks like that still involves running the collection which still has a cap limitation. I have been experimenting with the cli formatting and attempting to run this way and now experiencing “connect ETIMEDOUT …” errors.

So would the cli based runs actually run locally or are these originated from the cloud where I will have issues with accessing a network not publicly reachable?

Does anyone know if Newman would allow for “local” access or only work with networks reachable to the public?

I am not sure I fully understand what you are asking, but I use Newman all the time locally to access company network / intranet sites (not available to the public) .
The new Collection Runner limits are a pain, but I just use Newman now and have no issues.

@jdenault -your scenario sounds similar to the situation I’m explaining poorly. In my tests with scheduled collection runner I received a similar timeout error and support indicated that scheduled collection runs are run from the postman cloud and URLs must be public not private - so that option is off the table now. This doesn’t seem to matter for the manual collection runner from the app that is now limited to 25 runs per month. I wasn’t sure if the Postman CLI and Newman CLI have a similar setup where they somehow are running from the cloud and require URLs to be public instead of private or if they are truly local (which would make sense being from command line) and can access my private company server.

Troubleshooting a little further on my end I think I got around my timeout error by changing my VPN connectivity but now encountering different errors . Anyone familiar with an error indicating “self signed certificate at request”? I have tried looking around my collection and I don’t think I have certificates setup anywhere. Back to google for now

Ah, I see. I have never tried scheduling runs from the Collection Runner and so far I have just triggered Newman runs manually. Maybe I would face the same issue as you, should I try to do the same.

Can you run individual requests manually from Postman without getting the error? What happens when you try to manually trigger the Collection Runner? If you are getting the same errors, I would think it has something to do with your company’s network or firewall system in place.

So running individual requests (non collection runner) has never been an issue. My personal issue is that when I am running requests I typically am looking at running against a csv or json file. As of yet I don’t see a way to do that type of setup on a single non-collection runner request - it looks like data files are only available through some form of collection running whether it be manual/scheduled/cli. So my personal scenario (and looking like several others as well from various threads) is as follows:

  1. that manual runs are now limited to the point of being unusable
  2. scheduled won’t work in my scenario because we don’t allow the public world to talk to our private server and Postman Cloud needs to be able to communicate to the URL from the public side of things
  3. exploring CLI

I think I may have “fixed” my cert issue by toggling the SSL cert option in the collection settings - this will require additional testing though to validate as I was trying to run just very basic testing initially.

Thanks for the responses - sounds like I’m not the only one with this specific situation at least

Both Newman and Postman CLI run locally and can access your collection.

Check your Postman variables and SSL settings. For example, you can disable SSL validation with the

--insecure option which according to the documentation, “turns off SSL verification checks and allows self-signed SSL certificates.”

Thanks for clarifying for me. I have had some further success in additional testing. I have found that for whatever reason I have needed to toggle on/off the SSL cert setting on my account and on each individual request as well despite these settings all appearing to be disabled by default. Once I tweaked by VPN setting to correct my timeout issues and then fumbled through the re-disabling of cert toggles things seem to look more promising. The manual collection runner would still be much easier as this seems to be what is constantly referenced in most of the available videos and documentation out there. I have really enjoyed your videos that cover different aspects of Postman in general. Keep up the good work!

1 Like