Postman API call 502.3 error when doing collection running, but works when run manually each API

Hello All,

I’m new in API testing please bear with me.
I’m using Postman to test our API. I run a bunch of request using run collection on the entire collection but it always returns 502.3 Error on a random POST request, but when I tried to request it standalone it has no issue and it returns the POST request that I’ve selected. It only happens when I run collection test on the entire collection and it returns 502.3 randomly

502.3 Error when running collection test on the entire collection.

No Issue when run request on standalone.

On the console it says

JSONError: Unexpected token ‘<’ at 1:1

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" " ^

Checking the IIS Logs it shows that it is a 502.3 with Error code 12030. Upon doing research it means it is a ERROR_WINHTTP_CONNECTION_ERROR

“The connection with the server has been reset or terminated, or an incompatible SSL protocol was encountered. For example, WinHTTP version 5.1 does not support SSL2 unless the client specifically enables it.”

Any idea on how to fix this? Is this a connection issue? The server on which I’m requesting API is on a VPN.

Thank you all.