Passing syntax using Search inside sitecore item returns 400 error

My question: I am trying to send a GET request to Sitecore from postman tool for searching a term inside a Sitecore item using the following request- https://demosc.dev.local/sitecore/api/ssc/item/1FB673FA-C0E0-4174-BA8F-2C170BB71BCD/search?term=State&database=master. But I am getting a 400 error saying bad syntax.

Details (like screenshots):

How I found the problem: The error is showing in postman response

I’ve already tried:
I have referred the following documentation The RESTful API for the ItemService under the last section “Run a stored Sitecore search” with the syntax provided, but still getting error, not sure where I am getting wrong.

Can you please help on this issue?

1 Like

Hi @vijayarajanv

Looks like you haven’t saved some changes (orange dots in the tabs)… Could you ensure you have saved your changes, try again and update to say if it still doesn’t work?

Hi,

Thanks. After saving and sending the request, I am getting the following error

“Message”: “No HTTP resource was found that matches the request URI ‘https://demosc.dev.local/sitecore/api/ssc/1FB673FA-C0E0-4174-BA8F-2C170BB71BCD/search?term=state&database=master’.”,
“MessageDetail”: “No type was found that matches the controller named ‘search’.”

Can you please help?